cd949a3375
- Added driver for synthesized sounds - Added Tatsuyuki Satoh's YM3812 emulator - Added support to The Player 6.0a modules (using Sylvain "Asle" Chipaux's P60A loader) - Added seek capability to XMMS plugin - Added (very) experimental AIX driver - Added envelope point sanity checks (fixed "Beautiful Ones" IT envelope bug reported by Chris Cox) - Added support to dynamic linked drivers (for better packaging) - Added option to package only DFSG-compliant code - Fixed audioio.h detection in OpenBSD 2.8 (by Chris Cox <cox.family@sk.sympatico.ca>) - Max. filter cutoff value changed from 254 to 253 to avoid problems in "Beautiful Ones") - Fixed external drivers problem with the XMMS plugin (reported by greg <gjones@computelnet.com>) - Fixed xmp_ord_set() bug (was calling XMP_ORD_PREV) - Fixed period calculation algorithm (that was an OLD bug!) - Started adding support to MED 1.11, 1.12, 2.00 and 3.22 - Replaced RPM spec with Dominik Mierzejewski's version
13 lines
434 B
Text
13 lines
434 B
Text
$NetBSD: patch-ad,v 1.2 2002/01/29 07:41:28 martti Exp $
|
|
|
|
--- src/main/Makefile.orig Tue Jan 16 01:54:02 2001
|
|
+++ src/main/Makefile Mon Jan 28 15:32:24 2002
|
|
@@ -7,7 +7,7 @@
|
|
XDEPS =
|
|
BINS = xmp $(X_XMP)
|
|
XLIBS = -L../../lib -lxmp -lm #-lefence
|
|
-X11LIBS = -lX11 -lXext
|
|
+X11LIBS = -lX11 -lXext -Wl,-R${X11BASE}/lib
|
|
XPMS = bg1.xpm bg2.xpm bg3.xpm
|
|
DFILES = Makefile $(OBJS:.o=.c) $(X11OBJS:.o=.c) main.c xpanel.h $(XPMS) \
|
|
simple.c
|