pkgsrc/lang/gcc3/patches/patch-af
seb 1cd5dcea8a Make all gcc3-* packages use a single distinfo file from gcc3/distinfo and
a single patch directory from gcc3/patches/.
Also Move gcc3-c/{Makefile.common,language.mk} into gcc3/.
2004-04-10 15:47:08 +00:00

18 lines
675 B
Text

$NetBSD: patch-af,v 1.3 2004/04/10 15:47:08 seb Exp $
--- gcc/cppspec.c Wed Jul 23 02:40:54 2003
+++ gcc/cppspec.c Fri Jul 25 17:57:41 2003
@@ -85,6 +85,13 @@
is_cpp_driver = 1;
+ /* NetBSD uses __GNUC__ and friends in header files processed with cpp
+ regularly. Default to old behaviour here. XXX - move me to
+ config/netbsd.h "DEFAULT_CPP_NEED_NO_GCC". */
+#ifdef DEFAULT_CPP_NEED_NO_GCC
+ need_no_gcc = DEFAULT_CPP_NEED_NO_GCC;
+#endif
+
/* First pass. If we see an -S or -c, barf. If we see an input file,
turn off read_stdin. If we see a second input file, it is actually
the output file. If we see a third input file, barf. */