pkgsrc/audio/mp3blaster/patches/patch-al
cube b6c92f8952 Update to version 3.2.0.
V3.2.0 2003/11/28
=================
-Updated source to compile with recent gcc compilers
-Pausing mp3/wav/ogg playback releases the sound device
-Better mp3 integrity checks. Songs that didn't previously play (or only
 partly), should now play fine (as in, the bits that are valid)
-Fixed a bug that would hang mp3blaster if you'd be in a dir that was deleted
 meanwhile.
-bugfix that could crash mp3blaster after a request to quit (..)
-bugfix that failed to redraw screen correctly after operations that
 required input (such as convert to wav, enter group name, ..)
-fixed a bug that could crash mp3blaster on opening oggs when sound device
 was busy.
-Check if the playlist directory actually exists before trying to write
 a playlist
-Added '--repeat/-R' command line option
-Applied LIRC support patch from Olgierd Pieczul .
 Thanks a lot!
2003-12-03 12:31:36 +00:00

43 lines
1.6 KiB
Text

$NetBSD: patch-al,v 1.2 2003/12/03 12:31:37 cube Exp $
--- configure.in.orig 2003-10-26 16:40:37.000000000 +0100
+++ configure.in
@@ -17,7 +17,7 @@ AC_C_BIGENDIAN
dnl Checks for library functions.
AC_PROG_GCC_TRADITIONAL
-AC_CHECK_FUNCS(strdup strstr)
+AC_CHECK_FUNCS(strdup strstr getopt_long_only)
AC_LANG_CPLUSPLUS
@@ -220,7 +220,7 @@ AC_CHECK_HEADERS(fcntl.h malloc.h sys/io
AC_CHECK_HEADERS(bool.h)
AC_CHECK_HEADERS(pthread.h pthread/mit/pthread.h pth.h)
AC_CHECK_HEADERS(curses.h,HAVE_CURSES_H=1)
-AC_CHECK_HEADERS(sys/soundcard.h machine/soundcard.h soundcard.h getopt.h)
+AC_CHECK_HEADERS(sys/soundcard.h machine/soundcard.h soundcard.h)
AC_CHECK_HEADER(sys/soundcard.h,HAVE_SYS_SOUNDCARD_H=1)
AC_CHECK_HEADER(machine/soundcard.h,HAVE_MACHINE_SOUNDCARD_H=1)
AC_CHECK_HEADER(soundcard.h,HAVE_SOUNDCARD_H=1)
@@ -355,15 +355,17 @@ dnl CXXFLAGS="$CXXFLAGS -D__NO_MATH_INLI
dnl check for Network Audio System library
-LDFLAGS="$LDFLAGS -L../mpegsound -L../nmixer"
+LDFLAGS="$LDFLAGS -L../mpegsound -L../nmixer -L../getopt"
LIBMPEGSOUND="-lmpegsound"
LIBNMIXER="-lnmixer"
+LIBGETOPT="-lgetopt"
AC_SUBST(LIBMPEGSOUND)
AC_SUBST(LIBNMIXER)
+AC_SUBST(LIBGETOPT)
-SRCDIRS="mpegsound nmixer src doc doc/charmap"
+SRCDIRS="getopt mpegsound nmixer src doc doc/charmap"
AC_SUBST(SRCDIRS)
-AC_OUTPUT(src/Makefile mpegsound/Makefile Makefile nmixer/Makefile doc/Makefile doc/charmap/Makefile)
+AC_OUTPUT(getopt/Makefile src/Makefile mpegsound/Makefile Makefile nmixer/Makefile doc/Makefile doc/charmap/Makefile)
PTHREADS_OR_PTH="pthreads"
if test "$HAVE_PTH" = "yes" ; then PTHREADS_OR_PTH="pth" ; fi