pkgsrc/math/metis/patches/patch-ab
jtb 6216dc74db Initial import of metis:
METIS is a family of programs for partitioning unstructured graphs and
hypergraphs and computing fill-reducing orderings of sparse matrices.
The underlying algorithms used by METIS are based on the
state-of-the-art multilevel paradigm that has been shown to produce
high quality results and scale to very large problems.  It is
available both as a set of stand-alone programs and as a library.
2001-02-10 04:18:37 +00:00

22 lines
409 B
Text

$NetBSD: patch-ab,v 1.1.1.1 2001/02/10 04:18:37 jtb Exp $
--- Lib/Makefile.orig Wed Feb 7 21:14:38 2001
+++ Lib/Makefile
@@ -2,7 +2,7 @@
INCLUDES = -I.
-CFLAGS = $(COPTIONS) $(OPTFLAGS) $(INCLUDES)
+CFLAGS += $(COPTIONS) $(OPTFLAGS) $(INCLUDES)
LD = $(CC) -L.
@@ -21,7 +21,7 @@
$(CC) $(CFLAGS) -c $*.c
../libmetis.a: $(OBJS)
- $(AR) $@ $(OBJS)
+ $(AR) rv $@ $(OBJS)
$(RANLIB) $@
clean: