New extensions: * GL_AMD_blend_minmax_factor * GL_AMD_sample_positions * GL_EXT_x11_sync_object * GL_NV_texture_multisample * GL_NV_video_capture * GLX_NV_video_capture * WGL_NV_DX_interop * WGL_NV_video_capture Bug fixes: * Define GLEW_NO_GLU for no glu dependency. * mx suffix for GLEW MX libraries, build both libraries by default. * Cygwin build improvements * Soname of GLEWmx shared libraries * Query GL extension string only once * GLX_OML_sync_control no longer requires C99 * glDraw*InstancedARB moved from GL_ARB_draw_instanced to GL_ARB_instanced_arrays * glFramebufferTextureLayerEXT moved from GL_EXT_geometry_shader4 to GL_EXT_texture_array * Fixes for BSD build
13 lines
348 B
Text
13 lines
348 B
Text
$NetBSD: patch-ad,v 1.3 2011/07/13 19:47:38 adam Exp $
|
|
|
|
--- config/Makefile.darwin.orig 2011-04-27 16:16:34.000000000 +0000
|
|
+++ config/Makefile.darwin
|
|
@@ -13,7 +13,7 @@ endif
|
|
LDFLAGS.STATIC =
|
|
LDFLAGS.DYNAMIC =
|
|
WARN = -Wall -W
|
|
-POPT = -O2
|
|
+POPT ?= -O2
|
|
BIN.SUFFIX =
|
|
LIB.SONAME = lib$(NAME).$(SO_MAJOR).dylib
|
|
LIB.DEVLNK = lib$(NAME).dylib
|