c86cc7ec0f
Fruit is a chess engine. If you seek maximum playing strength, Fruit is your choice! Fruit is vice world computer chess champion 2005 and one of the strongest chess programs in the world. Fruit has a unique playing style, making it a good addition to any chess-engine collection. Fruit comes with a customised opening book and has many features which make it interesting especially for the engine enthusiast and serious correspondence player.
41 lines
730 B
Text
41 lines
730 B
Text
$NetBSD: patch-aa,v 1.1.1.1 2006/10/02 20:05:20 rillig Exp $
|
|
|
|
--- src/Makefile.orig 2005-06-17 09:41:34.000000000 +0200
|
|
+++ src/Makefile 2006-08-28 12:49:40.000000000 +0200
|
|
@@ -11,7 +11,7 @@ OBJS = attack.o board.o book.o eval.o fe
|
|
|
|
# rules
|
|
|
|
-all: $(EXE) .depend
|
|
+all: $(EXE)
|
|
|
|
clean:
|
|
$(RM) *.o .depend gmon.out
|
|
@@ -19,8 +19,7 @@ clean:
|
|
# general
|
|
|
|
CXX = g++
|
|
-CXXFLAGS = -pipe
|
|
-LDFLAGS = -lm
|
|
+LDFLAGS += -lm
|
|
|
|
# C++
|
|
|
|
@@ -32,17 +31,7 @@ CXXFLAGS += -O3 -fstrict-aliasing
|
|
CXXFLAGS += -fomit-frame-pointer
|
|
# CXXFLAGS += -march=athlon-xp # SELECT ME
|
|
|
|
-# strip
|
|
-
|
|
-LDFLAGS += -s
|
|
-
|
|
# dependencies
|
|
|
|
$(EXE): $(OBJS)
|
|
$(CXX) $(LDFLAGS) -o $@ $(OBJS)
|
|
-
|
|
-.depend:
|
|
- $(CXX) -MM $(OBJS:.o=.cpp) > $@
|
|
-
|
|
-include .depend
|
|
-
|