pkgsrc/devel/clib/patches/patch-ab
tonnerre 3b9dd3d374 Import clib version 0.2.2.
The clib provides advanced features to the C programming language,
such as dynamically resizing arrays, hash tables or operations
like establishing a TCP connection to a string.
2010-04-27 23:52:53 +00:00

13 lines
561 B
Text

$NetBSD: patch-ab,v 1.1.1.1 2010/04/27 23:52:53 tonnerre Exp $
--- configure.ac
+++ configure.ac
@@ -40,7 +40,7 @@ AC_CHECK_LIB([nbcompat], [main], [LIBS="-lnbcompat $LIBS"])
# Checks for header files.
AC_CHECK_HEADERS([string.h strings.h memory.h stdlib.h unistd.h queue.h \
sys/types.h sys/queue.h nbcompat/queue.h assert.h stddef.h \
- sys/socket.h netdb.h])
+ sys/socket.h netdb.h netinet/in.h netinet6/in6.h])
CL_IFDEF(SLIST_HEAD, [SLIST_HEAD(name,type)],
[struct name { struct type *slh_first; /* first element */ }],
[Singly-linked list head])