pkgsrc/x11/fltk/patches/patch-ae
jlam d2241bc129 Update fltk to 1.0.11. Changes from version 1.0.10 include bugfixes and:
- Added new const const pointer versions of pixmap functions to eliminate
  an annoying pointer warning message that was generated by the Sun and
  other C++ compilers.

- Eliminated all "var hides class::var" warnings.

- Eliminated all "string literal converted to char *" warnings.

- The file chooser buttons use user_data() rather than the label to decide
  what to do, allowing the label to be somewhat cleaner.

- Fl_has_idle only tested N-1 callbacks and missed one.

- Fl_Gl_Window has a new method to allow you to get and set the context:

      void Fl_Gl_Window::context(void*, int destroy = 0)
      void* Fl_Gl_Window::context() const;

  Return or set a pointer to the GLContext that this window is using. This
  is a system-dependent structure, but it is portable to copy the context
  from one window to another. You can also set it to NULL, which will
  force FLTK to recreate the context the next time make_current() is
  called, this is useful for getting around bugs in OpenGL implementations.

  If destroy_flag is true the context will be destroyed by fltk when the
  window is destroyed, or when the mode() is changed, or the next time
  context(x) is called.

- Added Fl::add_check(...), Fl::remove_check, and Fl::has_check. These are
  similar to idle callbacks but are only called just before it waits for
  new events.  They can be used to watch for changes in global state and
  respond to them.

- Added simple FLTK and FLUID manual pages.
2001-05-26 06:37:45 +00:00

28 lines
746 B
Text

$NetBSD: patch-ae,v 1.2 2001/05/26 06:37:46 jlam Exp $
--- fluid/Makefile.orig Mon Jan 22 10:13:38 2001
+++ fluid/Makefile
@@ -49,9 +49,9 @@
include ../makeinclude
-$(PROGRAM) : $(OBJECTS) ../lib/$(LIBNAME)
+$(PROGRAM) : $(OBJECTS) $(LIBFLTK)
echo Linking $@...
- $(CXX) -L../lib $(LDFLAGS) -o $(PROGRAM) $(OBJECTS) -lfltk $(LDLIBS)
+ $(CXX) $(LDFLAGS) -o $(PROGRAM) $(OBJECTS) $(LINKFLTK) $(LDLIBS)
clean :
-@ rm -f *.o $(PROGRAM) $(CLEAN) core *~ makedepend
@@ -63,9 +63,9 @@
install: $(PROGRAM)
echo "Installing FLUID..."
- strip $(PROGRAM)
-mkdir -p $(bindir)
- cp $(PROGRAM) $(bindir)/$(PROGRAM)
+ $(INSTALL_BIN) $(PROGRAM) $(bindir)/$(PROGRAM)
+ strip $(bindir)/$(PROGRAM)
chmod 755 $(bindir)/$(PROGRAM)
uninstall: