8c191c0ed9
databases/sqsh databases/sqsh-motif databases/sqsh-x11 The latter two are now just databases/sqsh built with a specific set of options. Changes include: + Add options.mk that supports three options: sqsh-motif Motif GUI sqsh-xaw Athena GUI sybase-openclient Use real Sybase Note that USE_SYBASE_OPENCLIENT is a legacy variable for the new global "sybase-openclient" option. + Remove Makefile.common and move all logic into sqsh/Makefile and sqsh/options.mk. + Remove section in patch-aa that tried to deal with termcap/curses issues for readline. That is now automatically taken care of in pkgsrc through termcap.buildlink3.mk, which is included here indirectly by readline/buildlink3.mk. + Add full DESTDIR support. + Bump the PKGREVISION for sqsh, sqsh-motif and sqsh-x11 to 5. All three packages now track and use the same PKGREVISION number.
31 lines
822 B
Text
31 lines
822 B
Text
$NetBSD: patch-aa,v 1.6 2008/04/22 16:23:36 jlam Exp $
|
|
|
|
--- configure.orig 2001-11-09 08:58:04.000000000 -0500
|
|
+++ configure
|
|
@@ -1209,6 +1209,8 @@ echo "configure:1191: checking Open Clie
|
|
SYBASE_OS="-lm -ldl -ldgc";;
|
|
aix*)
|
|
SYBASE_OS="-lm";;
|
|
+ netbsd*)
|
|
+ SYBASE_OS="-lm";;
|
|
*)
|
|
SYBASE_OS="-lm -ldl";;
|
|
esac
|
|
@@ -1459,7 +1461,7 @@ if eval "test \"`echo '$''{'ac_cv_lib_$a
|
|
echo $ac_n "(cached) $ac_c" 1>&6
|
|
else
|
|
ac_save_LIBS="$LIBS"
|
|
-LIBS="-lreadline "${READLINE_LIBS}" $LIBS"
|
|
+LIBS="-lreadline ${READLINE_LIBS} $LIBS"
|
|
cat > conftest.$ac_ext <<EOF
|
|
#line 1465 "configure"
|
|
#include "confdefs.h"
|
|
@@ -1493,7 +1495,7 @@ if eval "test \"`echo '$ac_cv_lib_'$ac_l
|
|
#define $ac_tr_lib 1
|
|
EOF
|
|
|
|
- LIBS="-lreadline $LIBS"
|
|
+ LIBS="-lreadline ${READLINE_LIBS} $LIBS"
|
|
|
|
else
|
|
echo "$ac_t""no" 1>&6
|