pkgsrc/devel/glib/patches/patch-ai
jlam e2afa97f51 Merge changes in packages from the buildlink2 branch that have
buildlink2.mk files back into the main trunk.  This provides sufficient
buildlink2 infrastructure to start merging other packages from the
buildlink2 branch that have already been converted to use the buildlink2
framework.
2002-08-25 18:38:05 +00:00

17 lines
651 B
Text

$NetBSD: patch-ai,v 1.3 2002/08/25 18:38:30 jlam Exp $
--- gthread/testgthread.c.orig Fri Jul 19 03:43:50 2002
+++ gthread/testgthread.c Fri Jul 19 03:42:15 2002
@@ -87,10 +87,10 @@
pthread_attr_setdetachstate (&pthread_attr, PTHREAD_CREATE_JOINABLE);
*/
pthread_create (&thread, &pthread_attr, (void *(*)(void *)) func, data);
- return GUINT_TO_POINTER (thread);
+ return thread;
}
#define join_thread(thread) \
- pthread_join ((pthread_t)GPOINTER_TO_UINT (thread), NULL)
+ pthread_join ((thread), NULL)
#define self_thread() GUINT_TO_POINTER (pthread_self ())
#else /* we are not having a thread implementation, do nothing */