pkgsrc/lang/erlang21/patches/patch-ab
jperkin 5e76b18444 erlang21: Re-import erlang version 21.3.
This is a copy of the previous lang/erlang of that release, with a few bits
tidied up, and configured to live alongside the newer lang/erlang package by
using a versioned library directory.

This version is required for at least databases/couchdb, and may be required
for other software that is incompatible with OTP 23.
2021-01-27 16:13:51 +00:00

15 lines
515 B
Text

$NetBSD: patch-ab,v 1.1 2021/01/27 16:13:51 jperkin Exp $
Build all .java files.
--- make/otp.mk.in.orig 2013-02-25 19:21:31.000000000 +0000
+++ make/otp.mk.in
@@ -179,7 +179,7 @@ endif
$(JAVA_DEST_ROOT)$(JAVA_CLASS_SUBDIR)%.class: %.java
- $(javac_verbose)CLASSPATH=$(CLASSPATH) $(JAVA) $(JAVA_OPTIONS) -d $(JAVA_DEST_ROOT) $<
+ $(javac_verbose)CLASSPATH=$(CLASSPATH) $(JAVA) $(JAVA_OPTIONS) -d $(JAVA_DEST_ROOT) *.java
# ----------------------------------------------------
# Emacs byte code compiling