generates distribution archives from a list of files. EPM provides a complete, cross-platform software distribution solution for your applications. ESP generates both native and "portable" script-based distribution packages complete with installation and removal scripts and standard install/uninstall GUIs. The installers can be customized with product logos, "readme" files, and click-wrap licenses as desired.
32 lines
711 B
Text
32 lines
711 B
Text
$NetBSD: patch-ab,v 1.1.1.1 2011/05/08 21:50:48 cheusov Exp $
|
|
|
|
DESTDIR support
|
|
--- configure.in.orig 2006-09-26 18:51:15.000000000 +0300
|
|
+++ configure.in
|
|
@@ -18,6 +18,7 @@ dnl
|
|
|
|
AC_INIT(epm.c)
|
|
AC_CONFIG_HEADER(config.h)
|
|
+AC_CONFIG_SRCDIR([epm.c])
|
|
AC_PREFIX_DEFAULT(/usr)
|
|
|
|
dnl Version number...
|
|
@@ -28,6 +29,8 @@ AC_SUBST(VERSION)
|
|
AC_SUBST(VERNUMBER)
|
|
AC_DEFINE_UNQUOTED(EPM_VERSION, "ESP Package Manager v$VERSION")
|
|
|
|
+AC_CANONICAL_HOST
|
|
+
|
|
dnl Get the operating system...
|
|
|
|
uname=`uname`
|
|
@@ -69,7 +72,9 @@ AC_ARG_WITH(softwaredir, [ --with-softw
|
|
dnl Checks for programs...
|
|
AC_PROG_CC
|
|
AC_PROG_CXX
|
|
+AC_PROG_INSTALL
|
|
AC_PROG_RANLIB
|
|
+
|
|
AC_PATH_PROG(AR,ar)
|
|
AC_PATH_PROG(CHMOD,chmod)
|
|
AC_PATH_PROG(CP,cp)
|