830708ba67
Packages changes: use buildlink2 and perl5/module.mk, documentation splitted in $PREFIX/share/doc/{rrdtool,html/rrdtool}/*. Okay'ed by wulf@. Changes since version 1.0.33: - bugfix, + enhancement, * contrib, = RELEASE --------------------------------------------- = 1.0.40 2002/10/11 -- Tobi - 2002/10/11 Jeffrey Wheat <jeff@nt.cetlink.net> updated php4 bindings to work with php 4.2.3 - 2002/10/07 Tomoyuki Murakami <tomoyuki@pobox.com> -z does not take an option - 2002/10/03 Gonzalo Augusto Arana Tagle <garana@uolsinectis.com.ar> fix for PREV() operator - 2002/08/01 Paul Clifford <paul.clifford@bbc.co.uk> fix for segfault in print_calc function + 2002/07/31 "Nenad Antic (EAB)" <Nenad.Antic@era.ericsson.se> rrdfetch manpage update - 2002/07/12 Gonzalo Augusto Arana Tagle <garana@uolsinectis.com.ar> PREV(xxx) match with DEF_NAM_FMT - 2002/07/12 Joerg Mertin <mertinj@europe.psi.com> fixed bindings for php4 - 2002/07/02 Philippe.Simonet@swisscom.com fixed DINF for win32 compile = 1.0.39 2002/06/20 -- Tobi + 2002/06/20 -- Gonzalo Augusto Arana Tagle <garana@uolsinectis.com.ar> * new CDEF feature PREV(x) which allows for funky new filters to be created easily + 2002/06/14 -- "Shipway, Steve" <steve.shipway@eds.com> * Improved docs for rrd_resize - Tobi * increassed commandline buffer in rrd_tool.c to 100 kilo Byte * in rrd_graph replace rint by ceil ...its more portable * remove // comments and replace with /* .... */ * due to popular demand change strftime format to %V for weeks + 2002/05/24 -- Joe Griffin <joe.griffin@mscsoftware.com> * config.guess and config.sub updates for IA64 = 1.0.38 2002/05/22 -- Tobi - 2002/05/12 -- Tobi * fix for crash in restore when used with existing file - 2002/04/29 -- Alex * fix for PRINT template parser in rrd_graph ... - 2002/04/16 -- Milan Obuch <milan.obuch@in.nextra.sk> * fix for --alt-mrtg + 2002/05/01 Wolfgang Schrimm <Wolfgang.Schrimm@urz.uni-heidelberg.de> * new subcommand xport = 1.0.37 2002/04/13 -- Tobi - 2002/04/14 -- Thierry Nkaoua <tnka@linux-sottises.net> * do not change LC_ALL but just LC_TIME ... = 1.0.36 2002/04/13 -- Tobi + 2002/04/13 -- Milan Obuch <milan.obuch@in.nextra.sk> * added new options to rrdgraph. Check the manpage for --overlay, --background, --unit, GD (graph output format) + 2002/04/09 -- Tobi * added setlocale and tzset calls to rrd_graph - 2002/04/09 -- Tobi * removed description of --goodfor and --refresh from rrdcgi - 2002/04/02 -- Paul Vixie <paul@vix.com> * rrd restore should not burn down existing files - 2002/03/23 -- Oliver Cook <ollie@uk.clara.net> * kill segfault in diff code for non digit input - 2002/03/23 -- Ashok Mandala <chakri063@yahoo.com> * make sure CDEFs work properly even when none of the contributing data sources start at start of the cdef. + 2002/03/20 -- David Lee <t.d.lee@durham.ac.uk> * Allow link builds through the ../configure syntax = 1.0.35 2002/03/20 -- Tobi - 2002/03/20 -- Tobi * fixed longstanding off by 1 bug in CDEF for cases where RRDs with different step sizes were mixed in one CDEF - 2002/03/13 -- Tobi * Deal with cases where Config{cc} contains an absolute path to perls C compiler. - 2002/03/14 -- Matt Galvin <mgalvin@dandd.com> * new OS detector config files which can deal with macos X = 1.0.34 2002/03/12 -- Tobi - 2002/02/12 -- Tobi * replaced zlib 1.1.3 with 1.1.4 - 2002/02/06 -- Alexander Schwartz <alexander.schwartz@gmx.net> * allow rrdcgi to deal with umlauts - 2001/12/27 -- Tom.Bertelson@gecapital.com * fix overflow error in rrd_fetch - 2001/11/28 -- Richard A. Steenbergen <ras@e-gerbil.net> * allow + - and ' ' in printfsring - 2001/03/31 -- Tobi * added 'all' dependancy to site-perl-install rule as many seem to skip this step when instaling cricket ... probably an incomplete cricket doku. - 2001/03/02 -- Mike Franusich <mike@franusich.com> * filedescriptor leak fixed in rrd_open for faild open attempts. - 2001/03/01 -- Tobi * test if compiler perl wants to use for building its modules is available on the system * zlib wants to be linked with -fpic on HPUX or it breaks ...
175 lines
7.6 KiB
Text
175 lines
7.6 KiB
Text
$NetBSD: patch-ar,v 1.4 2003/02/16 23:08:59 seb Exp $
|
|
|
|
--- src/Makefile.in.orig Fri Oct 11 18:42:53 2002
|
|
+++ src/Makefile.in
|
|
@@ -15,6 +15,10 @@
|
|
#ACLOCAL_M4 = $(top_srcdir)/config/aclocal.m4
|
|
#AUTOHEADER = @AUTOHEADER@ --localdir=$(top_srcdir)/config
|
|
|
|
+#COMPILE = $(CC) $(DEFS) $(INCLUDES) $(AM_CPPFLAGS) $(CPPFLAGS) $(AM_CFLAGS) $(CFLAGS) $(CFLAGS_EXTRA)
|
|
+#LTCOMPILE = $(LIBTOOL) --mode=compile $(CC) $(DEFS) $(INCLUDES) $(AM_CPPFLAGS) $(CPPFLAGS) $(AM_CFLAGS) $(CFLAGS) $(CFLAGS_EXTRA)
|
|
+#LINK = $(LIBTOOL) --mode=link $(CCLD) $(AM_CFLAGS) $(CFLAGS) $(CFLAGS_EXTRA) $(LDFLAGS) -o $@
|
|
+
|
|
|
|
SHELL = @SHELL@
|
|
|
|
@@ -69,13 +73,16 @@ host_triplet = @host@
|
|
target_alias = @target_alias@
|
|
target_triplet = @target@
|
|
CC = @CC@
|
|
+CGI_LIB_DIR = @CGI_LIB_DIR@
|
|
COMP_PERL = @COMP_PERL@
|
|
CPP = @CPP@
|
|
+GD_LIB_DIR = @GD_LIB_DIR@
|
|
LIBTOOL = @LIBTOOL@
|
|
NROFF = @NROFF@
|
|
PERL = @PERL@
|
|
PERLFLAGS = @PERLFLAGS@
|
|
PERL_MAKE_OPTIONS = @PERL_MAKE_OPTIONS@
|
|
+PNG_LIB_DIR = @PNG_LIB_DIR@
|
|
RANLIB = @RANLIB@
|
|
SO_EXT = @SO_EXT@
|
|
TCL_LD_SEARCH_FLAGS = @TCL_LD_SEARCH_FLAGS@
|
|
@@ -87,22 +94,7 @@ TCL_SHLIB_SUFFIX = @TCL_SHLIB_SUFFIX@
|
|
TROFF = @TROFF@
|
|
VERSION = @VERSION@
|
|
ZLIB_CFLAGS = @ZLIB_CFLAGS@
|
|
-
|
|
-CGI_INC_DIR = $(top_srcdir)/@CGI_LIB_DIR@
|
|
-GD_INC_DIR = $(top_srcdir)/@GD_LIB_DIR@
|
|
-PNG_INC_DIR = $(top_srcdir)/@PNG_LIB_DIR@
|
|
-ZLIB_INC_DIR = $(top_srcdir)/@ZLIB_LIB_DIR@
|
|
-
|
|
-CGI_LIB_DIR = $(top_builddir)/@CGI_LIB_DIR@
|
|
-GD_LIB_DIR = $(top_builddir)/@GD_LIB_DIR@
|
|
-PNG_LIB_DIR = $(top_builddir)/@PNG_LIB_DIR@
|
|
-ZLIB_LIB_DIR = $(top_builddir)/@ZLIB_LIB_DIR@
|
|
-
|
|
-INCLUDES = -I$(CGI_INC_DIR) -I$(GD_INC_DIR) -I$(PNG_INC_DIR) -I$(ZLIB_INC_DIR)
|
|
-
|
|
-#COMPILE = $(CC) $(DEFS) $(INCLUDES) $(AM_CPPFLAGS) $(CPPFLAGS) $(AM_CFLAGS) $(CFLAGS) $(CFLAGS_EXTRA)
|
|
-#LTCOMPILE = $(LIBTOOL) --mode=compile $(CC) $(DEFS) $(INCLUDES) $(AM_CPPFLAGS) $(CPPFLAGS) $(AM_CFLAGS) $(CFLAGS) $(CFLAGS_EXTRA)
|
|
-#LINK = $(LIBTOOL) --mode=link $(CCLD) $(AM_CFLAGS) $(CFLAGS) $(CFLAGS_EXTRA) $(LDFLAGS) -o $@
|
|
+ZLIB_LIB_DIR = @ZLIB_LIB_DIR@
|
|
|
|
RRD_C_FILES = gdpng.c getopt.c getopt1.c gifsize.c parsetime.c pngsize.c rrd_create.c rrd_diff.c rrd_dump.c rrd_info.c rrd_error.c rrd_fetch.c rrd_format.c rrd_graph.c rrd_last.c rrd_open.c rrd_resize.c rrd_restore.c rrd_tune.c rrd_update.c rrd_xport.c rrd_graph.h rrd_xport.h getopt.h ntconfig.h parsetime.h rrd_format.h rrd_tool.h rrd.h
|
|
|
|
@@ -114,8 +106,7 @@ RRD_C_FILES = gdpng.c getopt.c geto
|
|
# creates a ./.lib/*.al file that contains the PIC compiled object
|
|
# files.
|
|
|
|
-RRD_LIBS = $(CGI_LIB_DIR)/librrd_cgi.la $(GD_LIB_DIR)/librrd_gd.la $(PNG_LIB_DIR)/librrd_png.la $(ZLIB_LIB_DIR)/librrd_z.la
|
|
-
|
|
+RRD_LIBS = -lz -ljpeg -lgd -lcgi -lpng -lttf
|
|
|
|
lib_LTLIBRARIES = librrd.la
|
|
noinst_LTLIBRARIES = librrd_private.la
|
|
@@ -129,7 +120,7 @@ librrd_la_LDFLAGS = -version-info 0:0:0
|
|
include_HEADERS = rrd.h
|
|
|
|
librrd_private_la_LIBADD = $(RRD_LIBS)
|
|
-librrd_private_la_LDFLAGS = -static
|
|
+librrd_private_la_LDFLAGS = -prefer-pic
|
|
|
|
bin_PROGRAMS = rrdcgi rrdtool rrdupdate
|
|
|
|
@@ -153,17 +144,13 @@ DEFS = @DEFS@ -I. -I$(srcdir) -I../confi
|
|
CPPFLAGS = @CPPFLAGS@
|
|
LDFLAGS = @LDFLAGS@
|
|
LIBS = @LIBS@
|
|
-librrd_la_DEPENDENCIES = $(CGI_LIB_DIR)/librrd_cgi.la \
|
|
-$(GD_LIB_DIR)/librrd_gd.la $(PNG_LIB_DIR)/librrd_png.la \
|
|
-$(ZLIB_LIB_DIR)/librrd_z.la
|
|
+librrd_la_DEPENDENCIES =
|
|
librrd_la_OBJECTS = gdpng.lo getopt.lo getopt1.lo gifsize.lo \
|
|
parsetime.lo pngsize.lo rrd_create.lo rrd_diff.lo rrd_dump.lo \
|
|
rrd_info.lo rrd_error.lo rrd_fetch.lo rrd_format.lo rrd_graph.lo \
|
|
rrd_last.lo rrd_open.lo rrd_resize.lo rrd_restore.lo rrd_tune.lo \
|
|
rrd_update.lo rrd_xport.lo
|
|
-librrd_private_la_DEPENDENCIES = $(CGI_LIB_DIR)/librrd_cgi.la \
|
|
-$(GD_LIB_DIR)/librrd_gd.la $(PNG_LIB_DIR)/librrd_png.la \
|
|
-$(ZLIB_LIB_DIR)/librrd_z.la
|
|
+librrd_private_la_DEPENDENCIES =
|
|
librrd_private_la_OBJECTS = gdpng.lo getopt.lo getopt1.lo gifsize.lo \
|
|
parsetime.lo pngsize.lo rrd_create.lo rrd_diff.lo rrd_dump.lo \
|
|
rrd_info.lo rrd_error.lo rrd_fetch.lo rrd_format.lo rrd_graph.lo \
|
|
@@ -194,7 +181,7 @@ PACKAGE = @PACKAGE@
|
|
|
|
DISTFILES = $(DIST_COMMON) $(SOURCES) $(HEADERS) $(TEXINFOS) $(EXTRA_DIST)
|
|
|
|
-TAR = gtar
|
|
+TAR = tar
|
|
GZIP_ENV = --best
|
|
SOURCES = $(librrd_la_SOURCES) $(librrd_private_la_SOURCES) $(rrdcgi_SOURCES) $(rrdtool_SOURCES) $(rrdupdate_SOURCES)
|
|
OBJECTS = $(librrd_la_OBJECTS) $(librrd_private_la_OBJECTS) $(rrdcgi_OBJECTS) $(rrdtool_OBJECTS) $(rrdupdate_OBJECTS)
|
|
@@ -203,7 +190,7 @@ all: all-redirect
|
|
.SUFFIXES:
|
|
.SUFFIXES: .S .c .lo .o .s
|
|
$(srcdir)/Makefile.in: Makefile.am $(top_srcdir)/configure.in $(ACLOCAL_M4)
|
|
- cd $(top_srcdir) && $(AUTOMAKE) --gnu --include-deps src/Makefile
|
|
+ cd $(top_srcdir) && $(AUTOMAKE) --foreign --include-deps src/Makefile
|
|
|
|
Makefile: $(srcdir)/Makefile.in $(top_builddir)/config.status
|
|
cd $(top_builddir) \
|
|
@@ -377,60 +364,13 @@ distdir: $(DISTFILES)
|
|
@for file in $(DISTFILES); do \
|
|
d=$(srcdir); \
|
|
if test -d $$d/$$file; then \
|
|
- cp -pr $$d/$$file $(distdir)/$$file; \
|
|
+ cp -pr $$/$$file $(distdir)/$$file; \
|
|
else \
|
|
test -f $(distdir)/$$file \
|
|
|| ln $$d/$$file $(distdir)/$$file 2> /dev/null \
|
|
|| cp -p $$d/$$file $(distdir)/$$file || :; \
|
|
fi; \
|
|
done
|
|
-gdpng.lo gdpng.o : gdpng.c ../libpng-1.0.9/png.h ../zlib-1.1.4/zlib.h \
|
|
- ../zlib-1.1.4/zconf.h ../libpng-1.0.9/pngconf.h ../gd1.3/gd.h
|
|
-getopt.lo getopt.o : getopt.c ../config/config.h getopt.h
|
|
-getopt1.lo getopt1.o : getopt1.c ../config/config.h getopt.h
|
|
-gifsize.lo gifsize.o : gifsize.c
|
|
-parsetime.lo parsetime.o : parsetime.c rrd_tool.h ../config/config.h \
|
|
- rrd.h getopt.h rrd_format.h ../gd1.3/gd.h
|
|
-pngsize.lo pngsize.o : pngsize.c ../libpng-1.0.9/png.h \
|
|
- ../zlib-1.1.4/zlib.h ../zlib-1.1.4/zconf.h \
|
|
- ../libpng-1.0.9/pngconf.h
|
|
-rrd_cgi.o: rrd_cgi.c rrd_tool.h ../config/config.h rrd.h getopt.h \
|
|
- rrd_format.h ../gd1.3/gd.h ../cgilib-0.4/cgi.h
|
|
-rrd_create.lo rrd_create.o : rrd_create.c rrd_tool.h ../config/config.h \
|
|
- rrd.h getopt.h rrd_format.h ../gd1.3/gd.h
|
|
-rrd_diff.lo rrd_diff.o : rrd_diff.c rrd_tool.h ../config/config.h rrd.h \
|
|
- getopt.h rrd_format.h ../gd1.3/gd.h
|
|
-rrd_dump.lo rrd_dump.o : rrd_dump.c rrd_tool.h ../config/config.h rrd.h \
|
|
- getopt.h rrd_format.h ../gd1.3/gd.h
|
|
-rrd_error.lo rrd_error.o : rrd_error.c rrd_tool.h ../config/config.h \
|
|
- rrd.h getopt.h rrd_format.h ../gd1.3/gd.h
|
|
-rrd_fetch.lo rrd_fetch.o : rrd_fetch.c rrd_tool.h ../config/config.h \
|
|
- rrd.h getopt.h rrd_format.h ../gd1.3/gd.h
|
|
-rrd_format.lo rrd_format.o : rrd_format.c rrd_tool.h ../config/config.h \
|
|
- rrd.h getopt.h rrd_format.h ../gd1.3/gd.h
|
|
-rrd_graph.lo rrd_graph.o : rrd_graph.c rrd_tool.h ../config/config.h \
|
|
- rrd.h getopt.h rrd_format.h ../gd1.3/gd.h rrd_graph.h \
|
|
- ../gd1.3/gdlucidan10.h ../gd1.3/gdlucidab12.h
|
|
-rrd_info.lo rrd_info.o : rrd_info.c rrd_tool.h ../config/config.h rrd.h \
|
|
- getopt.h rrd_format.h ../gd1.3/gd.h
|
|
-rrd_last.lo rrd_last.o : rrd_last.c rrd_tool.h ../config/config.h rrd.h \
|
|
- getopt.h rrd_format.h ../gd1.3/gd.h
|
|
-rrd_open.lo rrd_open.o : rrd_open.c rrd_tool.h ../config/config.h rrd.h \
|
|
- getopt.h rrd_format.h ../gd1.3/gd.h
|
|
-rrd_resize.lo rrd_resize.o : rrd_resize.c rrd_tool.h ../config/config.h \
|
|
- rrd.h getopt.h rrd_format.h ../gd1.3/gd.h
|
|
-rrd_restore.lo rrd_restore.o : rrd_restore.c rrd_tool.h \
|
|
- ../config/config.h rrd.h getopt.h rrd_format.h ../gd1.3/gd.h
|
|
-rrd_tool.o: rrd_tool.c rrd_tool.h ../config/config.h rrd.h getopt.h \
|
|
- rrd_format.h ../gd1.3/gd.h rrd_xport.h
|
|
-rrd_tune.lo rrd_tune.o : rrd_tune.c rrd_tool.h ../config/config.h rrd.h \
|
|
- getopt.h rrd_format.h ../gd1.3/gd.h
|
|
-rrd_update.lo rrd_update.o : rrd_update.c rrd_tool.h ../config/config.h \
|
|
- rrd.h getopt.h rrd_format.h ../gd1.3/gd.h
|
|
-rrd_xport.lo rrd_xport.o : rrd_xport.c rrd_tool.h ../config/config.h \
|
|
- rrd.h getopt.h rrd_format.h ../gd1.3/gd.h rrd_graph.h \
|
|
- rrd_xport.h
|
|
-
|
|
info-am:
|
|
info: info-am
|
|
dvi-am:
|