373e933b4f
Honor PKG_SYSCONFDIR and PKGMANDIR. Use SUBST framework instead of manual sed. And pkglintfy. Bump PKGREVISION.
33 lines
778 B
Text
33 lines
778 B
Text
$NetBSD: patch-ab,v 1.5 2007/08/25 09:00:46 obache Exp $
|
|
|
|
--- ppp/Makefile.orig 2000-11-07 05:45:44.000000000 +0000
|
|
+++ ppp/Makefile
|
|
@@ -29,7 +29,7 @@ BINMODE=554
|
|
BINMODE=4554
|
|
BINOWN= root
|
|
.endif
|
|
-BINGRP= network
|
|
+BINGRP= ${USERPPP_GROUP}
|
|
OS!= uname -s
|
|
.if ${OS} == FreeBSD
|
|
MAN8= ppp.8
|
|
@@ -90,7 +90,7 @@ CFLAGS+=-DNORADIUS
|
|
.else
|
|
.if !defined(RELEASE_CRUNCH)
|
|
SRCS+= radius.c
|
|
-LDADD+= -lradius
|
|
+LDADD+= -lradius -lssl
|
|
DPADD+= ${LIBRADIUS}
|
|
.endif
|
|
.endif
|
|
@@ -121,9 +121,8 @@ chap_ms.o mppe.o id.o nat_cmd.o radius.o
|
|
|
|
# To cope with uucplock changes:
|
|
# Note, uucplock.c and libutil.h do not really belong here !
|
|
-CFLAGS+=-I. -I../libhack
|
|
+CFLAGS+=-D_PATH_PPP=\"${PKG_SYSCONFDIR}\" -I. -I../libhack
|
|
SRCS+=uucplock.c
|
|
-BINDIR=/usr/sbin
|
|
|
|
.PATH: ${.CURDIR}/../libhack
|
|
|