4969e44866
# 2.0.7 : Minor feature addition * Change translations to include descriptions of elements. * Turkish translation contributed by Osman Köseli. # 2.0.6 : Minor bug fixes and feature addition * Sebastien Bacher provided french translation and patched some translation bugs. * Fixed some minor bugs in the internationalisation support. * Minor fix of Makefile to improve .rpm generation.
32 lines
923 B
Text
32 lines
923 B
Text
$NetBSD: patch-ab,v 1.2 2003/12/14 12:38:30 wiz Exp $
|
|
|
|
--- po/Makefile.orig 2003-08-09 21:34:22.000000000 +0200
|
|
+++ po/Makefile
|
|
@@ -8,8 +8,8 @@ FILES_PO:=$(wildcard *.po)
|
|
FILES_MO:=$(FILES_PO:.po=.mo)
|
|
datadir ?= /usr/share
|
|
|
|
-LOCALEDIR ?= $(datadir)/locale
|
|
-MSGFMT_OPT ?= -f -v -o
|
|
+LOCALEDIR ?= $(PREFIX)/$(PKGLOCALEDIR)/locale
|
|
+MSGFMT_OPT ?= -f -o
|
|
|
|
ifeq ($(enable_nls),1)
|
|
all: mo-files
|
|
@@ -18,9 +18,9 @@ mo-files: $(FILES_MO)
|
|
|
|
install:
|
|
$(MAKE) all
|
|
- for f in $(FILES_MO) ; do mkdir -p \
|
|
+ for f in $(FILES_MO) ; do $(BSD_INSTALL_DATA_DIR) \
|
|
$(INSTALL_PREFIX)$(LOCALEDIR)/`basename $$f .mo`/LC_MESSAGES ; \
|
|
- cp $$f $(INSTALL_PREFIX)$(LOCALEDIR)/`basename $$f .mo`/LC_MESSAGES/$(PACKAGE).mo ; done
|
|
+ $(BSD_INSTALL_DATA) $$f $(INSTALL_PREFIX)$(LOCALEDIR)/`basename $$f .mo`/LC_MESSAGES/$(PACKAGE).mo ; done
|
|
|
|
%.mo: %.po
|
|
$(MSGFMT) $(MSGFMT_OPT) $@ $<
|
|
@@ -35,4 +35,3 @@ endif
|
|
|
|
clean:
|
|
$(RM) $(FILES_MO)
|
|
-
|