4bec950918
Unison is a file-synchronization tool for Unix and Windows. It allows two replicas of a collection of files and directories to be stored on different hosts (or different disks on the same host), modified separately, and then brought up to date by propagating the changes in each replica to the other.
41 lines
1.3 KiB
Text
41 lines
1.3 KiB
Text
$NetBSD: patch-src_Makefile,v 1.1 2018/04/30 10:14:29 wiz Exp $
|
|
|
|
Correct installation procedure
|
|
--- src/Makefile.orig 2018-01-27 21:12:13.000000000 +0000
|
|
+++ src/Makefile
|
|
@@ -49,7 +49,7 @@ all:: INSTALL
|
|
|
|
INSTALL: $(NAME)$(EXEC_EXT)
|
|
# file isn't made for OS X, so check that it's there first
|
|
- (if [ -f $(NAME) ]; then ./$(NAME) -doc install > INSTALLATION; fi)
|
|
+## (if [ -f $(NAME) ]; then ./$(NAME) -doc install > INSTALLATION; fi)
|
|
|
|
########################################################################
|
|
## Miscellaneous developer-only switches
|
|
@@ -68,7 +68,7 @@ include Makefile.OCaml
|
|
######################################################################
|
|
# Installation
|
|
|
|
-INSTALLDIR = $(HOME)/bin/
|
|
+INSTALLDIR = ${DESTDIR}$(PREFIX)/bin/
|
|
|
|
# This has two names because on OSX the file INSTALL shadows the target 'install'!
|
|
install: doinstall
|
|
@@ -86,9 +86,7 @@ doinstall: buildexecutable
|
|
echo "makefile variable NAME not bound"; \
|
|
exit 1 \
|
|
; fi
|
|
- -mv $(INSTALLDIR)/$(NAME)$(EXEC_EXT) /tmp/$(NAME)-$(shell echo $$$$)
|
|
cp $(NAME)$(EXEC_EXT) $(INSTALLDIR)
|
|
- cp $(NAME)$(EXEC_EXT) $(INSTALLDIR)$(NAME)-$(MAJORVERSION)$(EXEC_EXT)
|
|
|
|
######################################################################
|
|
# Demo
|
|
@@ -344,7 +342,6 @@ tags:
|
|
*Makefile* \
|
|
; fi
|
|
|
|
-all:: TAGS
|
|
|
|
TAGS:
|
|
$(MAKE) tags
|