25bb13f087
Release 3.2.1 The release contains the fix the inclusion of both cpp11 and cpp17 headers on C++17 compilation. Also some additional tests for using string literals and string objects with modern compilers. Release 3.2 Optional support for C++ 17 std::string_view. Release 3.1.2 Fix for Issue 72. Release 3.1.1 Include the commits from the previous year. Release 3.1 This release adds one new API call: unchecked::replace_invalid(). Other changes are mostly about testing and installation. Release 3.0.3 A minor release that contains fix for Issue 31 Program fails to link when including utf8.h in multiple files. Release 3.0.2 This minor release contains: Fix of the project version number at CMakeLists.txt Continuous Integration with Google Tests and CircleCI Release 3.0.1 A minor release with a fix for a header guard. Release 3.0 This is a major release that introduces the following functionality: New convenience API for C++ 11 and later compilers. The library still works with C++ 98/03 compliant compilers, just without the new functions. advance() function works in both directions. The following deprecated functions were removed: previous() - deprecated since version 1.02. is_bom() - deprecated since version 2.3.
24 lines
877 B
Text
24 lines
877 B
Text
$NetBSD: patch-CMakeLists.txt,v 1.1 2021/12/29 17:00:23 adam Exp $
|
|
|
|
Do not install includes in a sub-directory.
|
|
|
|
--- CMakeLists.txt.orig 2021-12-28 18:19:18.000000000 +0000
|
|
+++ CMakeLists.txt
|
|
@@ -14,7 +14,7 @@ option(UTF8_SAMPLES "Enable building sam
|
|
add_library(utf8cpp INTERFACE)
|
|
target_include_directories(utf8cpp INTERFACE
|
|
"$<BUILD_INTERFACE:${CMAKE_CURRENT_SOURCE_DIR}/source>"
|
|
- $<INSTALL_INTERFACE:include/utf8cpp>
|
|
+ $<INSTALL_INTERFACE:include>
|
|
)
|
|
add_library(utf8::cpp ALIAS utf8cpp)
|
|
|
|
@@ -26,7 +26,7 @@ if(UTF8_INSTALL)
|
|
set(DEF_INSTALL_CMAKE_DIR ${CMAKE_INSTALL_LIBDIR}/cmake/utf8cpp)
|
|
endif()
|
|
|
|
- install(DIRECTORY source/ DESTINATION include/utf8cpp)
|
|
+ install(DIRECTORY source/ DESTINATION include)
|
|
install(TARGETS utf8cpp EXPORT utf8cppConfig)
|
|
install(EXPORT utf8cppConfig DESTINATION ${DEF_INSTALL_CMAKE_DIR})
|
|
endif()
|