00ca3edcba
From the changelog: 5.29 * Downgraded to Xcode 5.0.2 to make it possible to build savers that will still run on 10.6 and 10.7. Sigh. * Updated `webcollage' for recent changes. 5.28 * Fixed some compilation problems and intermittent crashes. * Turned off the OSX 10.6 enable_gc hack. It didn't work. 5.27 * New hacks, `tessellimage' and `projectiveplane'. * Added support for pthreads, because Dave Odell is a madman. * Updated `webcollage' for recent changes. * Minor iOS tweaks to the `analogtv' hacks. * X11: Don't assume Suspend = 0 implies "No DPMS". * Minor updates to `boxed' and `klein'. * Fixed possible crash in `apple2', `noseguy', `xmatrix', `shadebobs'. * Fixed possible crash in OSX preferences. * OSX Performance improvements. * Plugged some leaks. 5.26 * More auto-updater tweaks. 5.25 * Try harder to bypass Quarrantine and Gatekeeper in OSX installer. * Some files were missing from the tarball. 5.24 * Added "Automatically check for updates" option on OSX. * Updated feed-loading for recent Flickr changes. * Updated `webcollage' for recent Google changes. * Added Instagram and Bing as `webcollage' image sources. * Updated to latest autoconf. * Bug fixes. 5.23 * New hack, `geodesic'. * iOS and OSX: huge XCopyArea performance improvements. * More heuristics for using RSS feeds as image sources. * Improved Wikipedia parser. * Updated `webcollage' for recent Flickr changes. * Added Android to `bsod'. * OSX: Added a real installer. * iOS and OSX: fixed a font-metrics bug. * iOS: Fixed aspect ratio bug in non-rotating apps when launched in landscape mode. * Made `quasicrystal' work on weak graphics cards. * iOS: fixed `ifs'. * Better compression on icons, plists and XML files: smaller distribution and installation footprint. * Reverted that DEACTIVATE change. Bad idea. * `Phosphor' now supports amber as well as green.
49 lines
2.1 KiB
Text
49 lines
2.1 KiB
Text
$NetBSD: patch-ad,v 1.23 2014/08/12 15:57:14 hauke Exp $
|
|
|
|
--- driver/Makefile.in.orig 2014-06-08 21:43:53.000000000 +0000
|
|
+++ driver/Makefile.in
|
|
@@ -205,7 +205,7 @@ PDF2JPEG_LIBS = -framework Cocoa
|
|
SAVER_LIBS = $(LIBS) $(X_LIBS) $(XMU_LIBS) @SAVER_LIBS@ \
|
|
$(XDPMS_LIBS) $(XINERAMA_LIBS) $(GL_LIBS) $(X_PRE_LIBS) \
|
|
-lXt -lX11 -lXext $(X_EXTRA_LIBS) \
|
|
- $(PASSWD_LIBS)
|
|
+ $(PASSWD_LIBS) $(INTL_LIBS)
|
|
|
|
CMD_LIBS = $(LIBS) $(X_LIBS) \
|
|
$(X_PRE_LIBS) -lX11 -lXext $(X_EXTRA_LIBS)
|
|
@@ -226,7 +226,7 @@ SCRIPTS = $(SCRIPTS_1) @SCRIPTS_OSX@
|
|
HDRS = XScreenSaver_ad.h XScreenSaver_Xm_ad.h \
|
|
xscreensaver.h prefs.h remote.h exec.h \
|
|
demo-Gtk-conf.h auth.h mlstring.h types.h
|
|
-MEN_1 = xscreensaver.man xscreensaver-demo.man \
|
|
+MEN_1 = xscreensaver.man \
|
|
xscreensaver-command.man \
|
|
xscreensaver-text.man \
|
|
xscreensaver-getimage.man \
|
|
@@ -257,7 +257,7 @@ all: $(EXES) $(EXES2)
|
|
tests: $(TEST_EXES)
|
|
|
|
install: install-program install-ad install-scripts \
|
|
- install-gnome install-man install-xml install-pam
|
|
+ install-gnome install-man install-xml
|
|
uninstall: uninstall-program uninstall-ad \
|
|
uninstall-gnome uninstall-man uninstall-xml
|
|
|
|
@@ -292,7 +292,7 @@ install-program: $(EXES)
|
|
fi ; \
|
|
echo $$inst xscreensaver $(install_prefix)$(bindir)/xscreensaver ; \
|
|
$$inst xscreensaver $(install_prefix)$(bindir)/xscreensaver
|
|
- @for exe in xscreensaver-command xscreensaver-demo \
|
|
+ @for exe in xscreensaver-command \
|
|
xscreensaver-getimage @EXES_OSX@ ; do \
|
|
echo $(INSTALL_PROGRAM) $$exe $(install_prefix)$(bindir)/$$exe ; \
|
|
$(INSTALL_PROGRAM) $$exe $(install_prefix)$(bindir)/$$exe ; \
|
|
@@ -491,7 +491,7 @@ install-pam: xscreensaver.pam
|
|
|
|
# screensaver-properties.desktop
|
|
# into /usr/share/applications/
|
|
-install-gnome:: screensaver-properties.desktop
|
|
+xxxinstall-gnome:: screensaver-properties.desktop
|
|
@if [ "$(GTK_DATADIR)" != "" ]; then \
|
|
if [ ! -d "$(install_prefix)$(GTK_APPDIR)" ]; then \
|
|
echo $(INSTALL_DIRS) "$(install_prefix)$(GTK_APPDIR)" ;\
|