c788cdc7d8
since I'm most familiar with the hack to include the LessTif X11 config files. Relevant changes from version 0.91.8: * Build/Install Uil libs and Headers (and tests) by default. * Fixed some FontList interfaces to conform to the docs. Might fix memory leaks as well. * Ongoing work to use ANSI C89 as much as possible. Drop alternatives being used (e.g. bcopy() and friends) * The Motif 2.x Xme() funcs should now all exist in stubs at least; some had already been "implemented" earlier. * Build support for a Motif 2.1 compatible tree. This will soon replace the 2.0 tree. * Work in progres for creating XmPrint API. (2.1 functionality)
32 lines
969 B
Text
32 lines
969 B
Text
$NetBSD: patch-ax,v 1.1 2000/12/22 17:26:20 jlam Exp $
|
|
|
|
--- include/Motif-2.0/uil/Makefile.am.orig Wed Oct 25 06:16:07 2000
|
|
+++ include/Motif-2.0/uil/Makefile.am
|
|
@@ -8,10 +8,13 @@
|
|
#
|
|
# Install headers
|
|
#
|
|
-# Lets put the headers in a sub directory to avoid
|
|
-# poluting /usr/local with more directories for default installs.
|
|
+# Let's put the headers in a sub directory if not a default install.
|
|
#
|
|
+if DefaultVersion20
|
|
+uildir = $(includedir)/uil
|
|
+else
|
|
uildir = $(prefix)/LessTif/Motif2.0/include/uil
|
|
+endif
|
|
|
|
HEADERS1_2 = Uil.h UilDBDef.h UilDef.h UilSymDef.h UilSymGl.h
|
|
|
|
@@ -29,11 +32,4 @@
|
|
fi ; \
|
|
done
|
|
|
|
-endif
|
|
-install-data-hook:
|
|
-if Version_2_0
|
|
-if DefaultVersion20
|
|
- if [ -d $(DESTDIR)$(prefix)/include/uil ]; then rm -rf $(DESTDIR)$(prefix)/include/uil; else rm -f $(DESTDIR)$(prefix)/include/uil; fi
|
|
- (mkdir -p $(DESTDIR)$(prefix)/include && cd $(DESTDIR)$(prefix)/include && $(LN_S) ../LessTif/Motif2.0/include/uil uil)
|
|
-endif
|
|
endif
|