c788cdc7d8
since I'm most familiar with the hack to include the LessTif X11 config files. Relevant changes from version 0.91.8: * Build/Install Uil libs and Headers (and tests) by default. * Fixed some FontList interfaces to conform to the docs. Might fix memory leaks as well. * Ongoing work to use ANSI C89 as much as possible. Drop alternatives being used (e.g. bcopy() and friends) * The Motif 2.x Xme() funcs should now all exist in stubs at least; some had already been "implemented" earlier. * Build support for a Motif 2.1 compatible tree. This will soon replace the 2.0 tree. * Work in progres for creating XmPrint API. (2.1 functionality)
41 lines
1.1 KiB
Text
41 lines
1.1 KiB
Text
$NetBSD: patch-bd,v 1.1 2000/12/22 17:26:20 jlam Exp $
|
|
|
|
--- lib/Mrm-2.0/Makefile.am.orig Wed Aug 30 12:15:19 2000
|
|
+++ lib/Mrm-2.0/Makefile.am
|
|
@@ -45,7 +45,11 @@
|
|
-DX_LIB_PATH=\"@x_libraries@\" \
|
|
-DLESSTIFHOME=\"@prefix@\"
|
|
|
|
+if DefaultVersion20
|
|
+libdir = $(prefix)/lib
|
|
+else
|
|
libdir = $(prefix)/LessTif/Motif2.0/lib
|
|
+endif
|
|
|
|
lib_LTLIBRARIES= libMrm.la
|
|
|
|
@@ -67,24 +71,4 @@
|
|
rm $$i; \
|
|
fi ; \
|
|
done
|
|
-endif
|
|
-
|
|
-install-data-hook:
|
|
-if Version_2_0
|
|
-if LibtoolShared
|
|
- -rm -f $(DESTDIR)$(prefix)/lib/libMrm.so.2*
|
|
- (cd $(DESTDIR)$(prefix)/lib && $(LN_S) ../LessTif/Motif2.0/lib/libMrm.so.2* .)
|
|
-endif
|
|
-if DefaultVersion20
|
|
- -rm -f $(DESTDIR)$(prefix)/lib/libMrm.la
|
|
- (cd $(DESTDIR)$(prefix)/lib && $(LN_S) ../LessTif/Motif2.0/lib/libMrm.la .)
|
|
-if LibtoolShared
|
|
- -rm -f $(DESTDIR)$(prefix)/lib/libMrm.so
|
|
- (cd $(DESTDIR)$(prefix)/lib && $(LN_S) ../LessTif/Motif2.0/lib/libMrm.so .)
|
|
-endif
|
|
-if LibtoolStatic
|
|
- -rm -f $(DESTDIR)$(prefix)/lib/libMrm.a
|
|
- (cd $(DESTDIR)$(prefix)/lib && $(LN_S) ../LessTif/Motif2.0/lib/libMrm.a .)
|
|
-endif
|
|
-endif
|
|
endif
|