37 lines
1.1 KiB
Text
37 lines
1.1 KiB
Text
$NetBSD: patch-aa,v 1.5 2004/06/12 02:24:57 grant Exp $
|
|
|
|
--- ld/Makefile.orig 1994-02-20 09:32:12.000000000 +1100
|
|
+++ ld/Makefile
|
|
@@ -1,18 +1,17 @@
|
|
-CFLAGS =-O -DBSD_A_OUT -DSTANDARD_GNU_A_OUT
|
|
-LDFLAGS =-N -s
|
|
+.include "../Makefile.inc"
|
|
|
|
-OBJS =dumps.o io.o ld.o readobj.o table.o typeconv.o writebin.o
|
|
+CFLAGS +=-DBSD_A_OUT -DSTANDARD_GNU_A_OUT
|
|
+LDFLAGS =
|
|
|
|
-ld: $(OBJS)
|
|
- $(CC) $(LDFLAGS) $(OBJS) -o $@
|
|
+SRCS =dumps.c io.c ld.c readobj.c table.c typeconv.c writebin.c
|
|
|
|
-clean:
|
|
- rm -f $(OBJS) ld
|
|
-
|
|
-dumps.o: dumps.c const.h config.h obj.h type.h globvar.h
|
|
-io.o: io.c const.h config.h obj.h type.h globvar.h
|
|
-ld.o: ld.c const.h config.h byteord.h type.h globvar.h
|
|
-readobj.o: readobj.c const.h config.h byteord.h obj.h type.h globvar.h
|
|
-table.o: table.c const.h config.h align.h obj.h type.h globvar.h
|
|
-typeconv.o: typeconv.c const.h config.h type.h globvar.h
|
|
-writebin.o: writebin.c const.h config.h obj.h type.h globvar.h
|
|
+PROG =ld86
|
|
+
|
|
+BINDIR =${LOCALPREFIX}/bin
|
|
+MANDIR =${LOCALPREFIX}/man
|
|
+
|
|
+beforeinstall:
|
|
+ -mkdir -p ${BINDIR}
|
|
+ -mkdir -p ${MANDIR}/man1
|
|
+
|
|
+.include <bsd.prog.mk>
|