pkgsrc/emulators/simulavr/patches/patch-src_Makefile.in
mef 611e027d22 (pkgsrc)
simulavr asks for libiberty.a.
  With avr-gcc 4.5.3 and avr-binutils-2.23.2, binutils is installing
  libiberty.a
  But with new binutils-2.24, it won't install libiberty. Instead,
  avr-gcc-4.8.3 will provied libiberty.
  Makefile (of simulavr) now has pointer to PATH of libiberty now
  as:
    CONFIGURE_ARGS+=        --with-libiberty=${PREFIX}/lib/gcc/avr
(Add patches)
   patch-src_systemclock_cpp (rename from  patch-src_systemclock.cpp)
   patch-src_systemclock_h
   patch-src_traceval_cpp
   patch-src_traceval_h
     clang flags as resize unresolved reference,
     backport from git repository (as of 2013-09-15).
  patch-examples_atmel_key_StdDefs_c        Status: Locally Added
     passing argument 1 of 'strlen' differ in signedness [-Wpointer-sign]
2014-08-29 04:40:06 +00:00

17 lines
970 B
Text

$NetBSD: patch-src_Makefile.in,v 1.2 2014/08/29 04:40:06 mef Exp $
/usr/pkg/bin/swig -c++ -python -Ipython -o pysim ...
...
pysimulavr_wrap.cpp:146:20: fatal error: Python.h: No such file or directory
--- src/Makefile.in.orig 2013-07-07 10:12:33.000000000 +0900
+++ src/Makefile.in 2013-07-07 10:31:40.000000000 +0900
@@ -395,7 +395,7 @@
@USE_SWIG_TRUE@@USE_TCL_TRUE@TCL_LIB = @AVR_TCL_LIB@
@USE_SWIG_TRUE@@USE_TCL_TRUE@TCL_INCLUDE = @AVR_TCL_INCLUDE@
@PYTHON_USE_TRUE@@USE_SWIG_TRUE@PYTHON_MODUL_LIB = _pysimulavr@PYTHON_MODULE_EXTENSION@
-@PYTHON_USE_TRUE@@USE_SWIG_TRUE@PYTHON_XTRA_INC = -Ipython
+@PYTHON_USE_TRUE@@USE_SWIG_TRUE@PYTHON_XTRA_INC = -I@PREFIX@/include/python2.7 -Ipython
@PYTHON_USE_TRUE@@USE_SWIG_TRUE@PYTHON_MODUL_INTERFACE = $(srcdir)/python/pysimulavr.i
@PYTHON_USE_TRUE@@USE_SWIG_TRUE@nodist_lib_pysimulavr_la_SOURCES = pysimulavr_wrap.cpp
@PYTHON_USE_TRUE@@USE_SWIG_TRUE@lib_pysimulavr_la_CPPFLAGS = $(PYTHON_CPPFLAGS) $(PYTHON_XTRA_INC)