pkgsrc/audio/libmpg123/patches/patch-aa
bjs 146eaf55b5 Import libmpg123-1.5.1. This package provides the mpg123 project's
core decoder library, which the new mpg123 package will depend on.
Other software packages are beginning to write plug-ins for this
library, and so installing it seperately is worthwhile.

NOTE: I have encountered segfaults when attempting to use the jack
module, which is threaded, with mpg123 unless I linked mpg123 with
libpthread.  This may or may not apply to the library, though my
intuition is that it does not, as obviously the executable is
what calls lt_dlopen().  Thus, for now the Makefile and b3.mk of the
executable will pull in dlopen.buildlink3.mk, setting
DLOPEN_REQUIRE_PTHREADS=yes as necessary (last time I checked on
NetBSD 4.99, it was).
2008-09-07 00:56:15 +00:00

17 lines
337 B
Text

$NetBSD: patch-aa,v 1.1.1.1 2008/09/07 00:56:15 bjs Exp $
--- src/output/esd.c.orig 2008-08-29 02:43:51.000000000 -0400
+++ src/output/esd.c
@@ -18,6 +18,12 @@
#endif
#include "debug.h"
+#ifdef NETBSD
+#include <sys/ioctl.h>
+#include <sys/audioio.h>
+#endif
+
+
static unsigned esd_rate = 0, esd_format = 0, esd_channels = 0;