core decoder library, which the new mpg123 package will depend on. Other software packages are beginning to write plug-ins for this library, and so installing it seperately is worthwhile. NOTE: I have encountered segfaults when attempting to use the jack module, which is threaded, with mpg123 unless I linked mpg123 with libpthread. This may or may not apply to the library, though my intuition is that it does not, as obviously the executable is what calls lt_dlopen(). Thus, for now the Makefile and b3.mk of the executable will pull in dlopen.buildlink3.mk, setting DLOPEN_REQUIRE_PTHREADS=yes as necessary (last time I checked on NetBSD 4.99, it was).
13 lines
346 B
Text
13 lines
346 B
Text
$NetBSD: patch-ac,v 1.1.1.1 2008/09/07 00:56:15 bjs Exp $
|
|
|
|
--- src/term.c.orig 2008-08-29 02:43:56.000000000 -0400
|
|
+++ src/term.c
|
|
@@ -196,7 +196,7 @@ static void term_handle_input(mpg123_han
|
|
while(n > 0) {
|
|
fd_set r;
|
|
struct timeval t;
|
|
- char val;
|
|
+ unsigned char val;
|
|
|
|
t.tv_sec=0;
|
|
t.tv_usec=(do_delay) ? 10*1000 : 0;
|