d40203dfb7
Notable changes in version 9.4.3: The system-specific Icon configurations have been reorganized and renamed. The several BSD configurations have been merged into one. The macintosh configuration now supports the loadfunc function. A new porting guide has been written, and a new posix configuration has been added as a starting point in constructing new ports. The core library files remain stable. Notable changes include: - procs/dijkstra new procedures implement Dijkstra's control structures - procs/html add procedure for canonicalization of paths - procs/matrix2 new procedures for matrix manipulation - procs/nestlist new procedures for representing nested lists as strings - procs/printf add %e format and fix a rounding problem - progs/noise new program for producing a random bitstream - progs/unclog improve logic for combining adjacent entries - gprogs/dlgvu improve coverage map; allow altitude in GPS data - gprogs/gallery faster thumbnail loading for JPEG images - gprogs/img many new features - gprogs/sier better color choices - gprogs/trkvu accept GPS track logs with altitude as the last field The undocumented save function, which only worked on a few platforms, has been removed. Approved by <tnn>.
21 lines
677 B
Text
21 lines
677 B
Text
$NetBSD: patch-ax,v 1.6 2009/02/08 12:51:05 asau Exp $
|
|
|
|
--- src/runtime/Makefile.orig 2005-07-07 21:36:06.000000000 +0400
|
|
+++ src/runtime/Makefile 2009-02-08 01:43:04.000000000 +0300
|
|
@@ -41,7 +41,6 @@
|
|
cd ../common; $(MAKE)
|
|
$(CC) $(RLINK) -o iconx $(OBJS) $(XL) $(RLIBS) $(TL)
|
|
cp iconx ../../bin
|
|
- strip $(SFLAGS) ../../bin/iconx$(EXE)
|
|
|
|
xcnv.o: cnv.r $(HDRS)
|
|
../../bin/rtt -x cnv.r
|
|
@@ -306,7 +305,7 @@
|
|
../common/long.o ../common/time.o\
|
|
../common/xwindow.o ../common/alloc.o
|
|
ranlib rt.a 2>/dev/null || :
|
|
- cp -p rt.a rt.db ../common/dlrgint.o ../../bin
|
|
+ cp -p rt.a rt.db ../common/dlrgint.o ../../lib/icon
|
|
|
|
cnv.o: cnv.r $(HDRS)
|
|
../../bin/rtt cnv.r
|