da94ca1d61
* deletion of unattached GDL added. * Polish translation update by Emil. * fix UADDR list redisplay problem. * fix a crash of dc_gui2_stat when there is nothing to display. * add upload stat to dc_gui2_stat (only DCTC v0.85.9 provides upload logs). * fix a user display problem. If a user entering the hub is already created (used by GDL, upload, share list, ...), he was not displayed in the user clist. * Fix incorrect global stat values occuring when multiple 'done' files are loaded. * Bittorrent tab is handled by an external program: dc_gui2_bt * To ease development of future external program, most of the configuration is * now store in gconf instead gnome_config. * dc_gui2 command line parameters are back (dc_gui2 --help for the list). * update .spec file to support fedora (based on Sammy Atmadja modification).
29 lines
796 B
Text
29 lines
796 B
Text
$NetBSD: patch-ac,v 1.2 2010/06/02 13:08:22 adam Exp $
|
|
|
|
--- src/callbacks.c.orig 2004-01-21 15:57:32.000000000 +0000
|
|
+++ src/callbacks.c
|
|
@@ -30,7 +30,13 @@ $Id: callbacks.c,v 1.65 2004/01/21 15:57
|
|
#include <sys/socket.h>
|
|
#include <sys/un.h>
|
|
#include <math.h>
|
|
+#ifdef __linux__
|
|
#include <linux/sem.h>
|
|
+#else
|
|
+#ifndef SEMVMX
|
|
+#define SEMVMX 32767 /* semaphore maximum value */
|
|
+#endif
|
|
+#endif
|
|
#include <fcntl.h>
|
|
#include <signal.h>
|
|
#include <dirent.h>
|
|
@@ -75,6 +81,10 @@ $Id: callbacks.c,v 1.65 2004/01/21 15:57
|
|
#include "global_user.h"
|
|
#include "manage_chat.h"
|
|
|
|
+#ifndef MSG_NOSIGNAL
|
|
+#define MSG_NOSIGNAL 0
|
|
+#endif
|
|
+
|
|
static void build_start_dl_popup(int from_panel);
|
|
void on_load_selected_share_lists_button_clicked (GtkButton *button, gpointer user_data);
|
|
|