pkgsrc/devel/id-utils/patches/patch-ag
seb 1034334372 - Fix build failure - exposed after lastest modification of
../../devel/gettext-lib/buildlink.mk - due to incorrect usage of @INTLIBS@ in
  Automake's prog_LDADD variable. Thanks Johnny Lam for hints and explanations!
- While here get ride off build dependencies on auto* tools and GNU make by
  using a new set of patches and AUTOMAKE_OVERRIDE.
  Note: new Makefile.am files and hence their patches were generated with
  automake-1.1b!
- sort PLIST and use same `install-info' arguments as those generated by
  `make print-PLIST'.
- Fix broken dependencies when USE_XEMACS is defined.
2001-11-03 09:59:35 +00:00

25 lines
664 B
Text

$NetBSD: patch-ag,v 1.2 2001/11/03 09:59:36 seb Exp $
--- lisp/elisp-comp.orig Tue Aug 8 00:39:31 1995
+++ lisp/elisp-comp
@@ -28,13 +28,19 @@
if test $# = 0; then
echo 1>&2 "No files given to $0"
else
+ if test -z "$EMACS" || test "$EMACS" = "t"; then
+ # Value of "t" means we are running in a shell under Emacs.
+ # Just assume Emacs is called "emacs".
+ EMACS=emacs
+ fi
+
tempdir=elc.$$
mkdir $tempdir
cp $* $tempdir
cd $tempdir
echo "(setq load-path (cons nil load-path))" > script
- emacs -batch -l script -f batch-byte-compile *.el
+ $EMACS -batch -l script -f batch-byte-compile *.el
mv *.elc ..
cd ..