2852e17393
Inspired by PR#43126 from Wen Heping. While here, set LICENSE and TEST_TARGET. adns (1.4); urgency=low Improvements for multithreaded programs: * New documentation comment in adns.h explaining thread guarantees (or lack of them), replaces `single-threaded' note at the top. * Fix string conversion of adns_r_addr not to use a static buffer (function csp_addr) so as to make thread promise true. * Make an internal variable const-correct (expectdomain in pa_ptr). -- Ian Jackson <ian@davenant.greenend.org.uk> Tue, 17 Oct 2006 17:05:08 +0100 adns (1.3); urgency=low Portability fixes: * Cast ptrdiff_t to int for %.*s length in adnsheloex and adnslogres, as is required. (Report from Jim Meyering.) * In configure.in, quote macro name argument to define() to suppress spurious autoconf error. (Report from Mihai Ibanescu.) * Use autoconf's values for {bin,lib,include}dir rather than inventing our own from @exec_prefix@, making configure --libdir work. (Patch from Mihai Ibanescu.) * Remove spurious `_' from {bin,lib,include}dir Makefile variables. (Report from Mihai Ibanescu.) * Do away with `mismatch' variable in parse.c:adns__findrr_anychk so that overzealous GCC cannot complain about members of eo_fls being uninitialised. (Report from Jim Meyering.) -- Ian Jackson <ian@davenant.greenend.org.uk> Tue, 6 Jun 2006 20:22:30 +0100 adns (1.2); urgency=medium New features: * Support for SRV RRs. * Support for unknown RR types (according to RFC3597) via adns_r_unknown. * Allow `;'-comments in resolv.conf (report from Colin Charles). * New adnsheloex client courtesy of Tony Finch. * New adns_init_logfn etc. for having logging use a callback function. Bugfixes: * Fix error in prototype in definition of adns__parse_domain. * Add missing ENOTSOCK to hcommon.c.m4 (was already in hcommon.c!) Portability fixes prompted by Bernd Eckenfels, the Debian maintainer: * Correct type of various printf arguments: ptrdiff_t != int. * Do not print size of leaked blocks of memory (this causes a spurious regression test failure on some platforms). * Provide adns_if_none and adns_qf_none (which will help with compilers which complain about plain `0' being passed where an enum is wanted). * adnstest converts some errno values to EFOOBAR: all of the ones mentioned in adns.h, at least. This makes the regression test more portable (fixes problem noticed by Bernd Eckenfels). * Add -Wno-pointer-sign if GCC has that option. Documentation improvements: * Add documentation comment by definition of adns_r_ptr_raw type enum. * Document in adns.h EINVAL from adns_init meaning bad configuration. * Include several new references to related programs to README.html. * Redacted the TODO list. * New LICENCE.WAIVERS file for GPL-incompatility workarounds. * Clarified GPL-vs-LGPL: a bit less hostile and a bit more mercenary. * Copyright notices updated. Packaging changes: * Update MINOR to 2 and DISTVERSION and ADNS_VERSION_STRING to 1.2. * Reran autoconf/autoheader (autoconf Debian 2.13-54). * Create $(bin_dir) and $(lib_dir) on `make install', and also make a libadns.so.1 -> libadns.so.1.<minor> link. (Suggestions and patch from Nix of esperi.org.uk.) * Add .PHONY: install to Makefile, to help people with demented fs's. * Darwin listed in INSTALL. Minor test harness improvements: * Hgettimeofday calls Tensurerecordfile (was Tensureinput/outputfile). * Add bind(2) and listen(2) wrappers (for epithet, but harmless in adns). -- Ian Jackson <ian@davenant.greenend.org.uk> Sat, 8 Apr 2006 15:41:28 +0100
37 lines
983 B
Text
37 lines
983 B
Text
$NetBSD: patch-ab,v 1.4 2010/04/17 12:43:03 obache Exp $
|
|
|
|
--- src/Makefile.in.orig 2006-05-10 10:58:03.000000000 +0000
|
|
+++ src/Makefile.in
|
|
@@ -23,14 +23,14 @@
|
|
srcdir= @srcdir@
|
|
VPATH= @srcdir@
|
|
|
|
-TARGETS= libadns.a
|
|
+TARGETS= libadns.la
|
|
include $(srcdir)/../settings.make
|
|
include adns.make
|
|
|
|
install:
|
|
mkdir -p $(libdir) $(includedir)
|
|
set -xe; for f in $(TARGETS); \
|
|
- do $(INSTALL_DATA) $$f $(libdir)/$$f; done
|
|
+ do ${LIBTOOL} --mode=install $(INSTALL_DATA) $$f $(libdir)/$$f; done
|
|
$(INSTALL_DATA) $(srcdir)/../src/adns.h $(includedir)/adns.h
|
|
|
|
uninstall:
|
|
@@ -39,10 +39,10 @@ uninstall:
|
|
|
|
ALLOBJS= $(LIBOBJS)
|
|
|
|
-libadns.a: $(LIBOBJS)
|
|
- rm -f $@
|
|
- $(AR) cqv $@.new $(LIBOBJS)
|
|
- $(RANLIB) $@.new
|
|
- mv -f $@.new $@
|
|
+libadns.la: $(LIBOBJS)
|
|
+ ${LIBTOOL} --mode=link $(CC) $(LDFLAGS) -o $@ $(LIBOBJS:.o=.lo) -rpath ${PREFIX}/lib -version-info $(MAJOR):$(MINOR)
|
|
|
|
$(LIBOBJS): adns.h internal.h config.h
|
|
+
|
|
+.c.o:
|
|
+ ${LIBTOOL} --mode=compile $(CC) $(CFLAGS) -c $<
|