0c781833a6
While here, send patches upstream. Changes: * version 2.6.0 released 2015-11-17 ** User Visible Changes *** C++ scanners now use references instead of pointers. See the manual for details. *** A number of compiler warnings were addressed, so flex generated scanners should be quieter under compiler warning scenarios. *** Allow error reporting routines to accept varying number of arguments *** Removed deprecated 'register' storage class specifier *** Changeed output formats from octal to hexadecimal *** check limits before using array index cclp; resolves sf-166 *** Suppress clang warning about empty @param paragraph; resolves sf#158 *** Fixed malloc/realloc replacement, resolves sf bug#151. *** Adjusted buffer sizes on ia64. *** various documentation and code clean up fixes: resolves sf bugs #167, #168, among other patches. ** Flex Internals *** flex is now organized into subdirectories. This keeps the tree neater at the top level and puts like things near each other and unlike things away from each other. *** The test suite has been reorganized and is now run with the parallel test suite harness from automake. *** Cleaned up the automake parts of the build system to better reflect what automake does on its own. Also added a call to libtoolize in autogen.sh because autoreconf gets confused without a prior run of libtoolize. *** po/Makefile now includes a rule to fetch the latest translations from the translation project. "make -f po/Makefile getpo" from the top level of the flex tree will fetch the files. *** New da translation from the translation project
25 lines
654 B
Text
25 lines
654 B
Text
$NetBSD: patch-src_Makefile.in,v 1.1 2016/01/07 12:05:31 wiz Exp $
|
|
|
|
libfl* do not need to be linked against libintl, only the binaries do.
|
|
https://sourceforge.net/p/flex/bugs/198/
|
|
|
|
--- src/Makefile.in.orig 2015-11-17 16:19:45.000000000 +0000
|
|
+++ src/Makefile.in
|
|
@@ -302,7 +302,7 @@ LEX_OUTPUT_ROOT = @LEX_OUTPUT_ROOT@
|
|
LIBICONV = @LIBICONV@
|
|
LIBINTL = @LIBINTL@
|
|
LIBOBJS = @LIBOBJS@
|
|
-LIBS = @LIBINTL@ @LIBS@
|
|
+LIBS = @LIBS@
|
|
LIBTOOL = @LIBTOOL@
|
|
LIPO = @LIPO@
|
|
LN_S = @LN_S@
|
|
@@ -428,7 +428,7 @@ flex_SOURCES = \
|
|
filter.c \
|
|
regex.c
|
|
|
|
-LDADD = ../lib/libcompat.la
|
|
+LDADD = ../lib/libcompat.la @LIBINTL@
|
|
libfl_la_SOURCES = \
|
|
libmain.c \
|
|
libyywrap.c
|