pkgsrc/net/nasd/patches/patch-kernel__generate_dux_other_Makefile
dholland 698aeae4b5 Fix broken build.
(1) With gcc 4.5, cpp does not fold lines separated by a escaped
newline in the output. Therefore when nasd_rpcgen runs its rpc
definitions through cpp, what comes out contains syntax errors. The
parser then reports these with SIGSEGV. First fix the cpp plumbing to
use the cpp tool wrapper during build, and then have it use -traditional.

(2) On amd64, roughly half the build thinks it's actually i386. Patch
the other half to agree. This may not turn out to work, but it does
build instead of dumping out bizarre compile errors.
2012-06-02 23:34:56 +00:00

18 lines
706 B
Text

$NetBSD: patch-kernel__generate_dux_other_Makefile,v 1.1 2012/06/02 23:34:56 dholland Exp $
Set cpp and use -traditional when invoking nasd_rpcgen.
--- kernel_generate/dux/other/Makefile~ 2005-03-21 08:52:03.000000000 +0000
+++ kernel_generate/dux/other/Makefile
@@ -55,8 +55,9 @@ IMODE = 444
IOWNER = bin
IGROUP = bin
-NASD_RPCGEN = ../../../../bin/nasd_rpcgen
-NASD_RPCGEN_BIN = ${NASD_RPCGEN}
+NASD_RPCGEN = ${NASD_RPCGEN_BIN} ${NASD_RPCGEN_ARGS}
+NASD_RPCGEN_BIN = ../../../../bin/nasd_rpcgen
+NASD_RPCGEN_ARGS = -C 'cpp -traditional'
NASD_RPCGEN_INCLUDES = -I${MAKETOP}kernel/nasd/kernel_generate/dux -I${MAKETOP}kernel/nasd/kernel_generate/dux/other
include ${MAKEFILEPATH}/standard.mk