pkgsrc/inputmethod/xcin/patches/patch-ac
joerg 4e104a3d58 Add DragonFly support. Handle the different locale names in PLIST.
Based on patch from Jeffrey Hsu in private mail.
2006-04-28 18:12:29 +00:00

44 lines
1.1 KiB
Text

$NetBSD: patch-ac,v 1.4 2006/04/28 18:12:29 joerg Exp $
--- configure.orig 2001-11-27 14:21:17.000000000 +0000
+++ configure
@@ -5170,6 +5170,13 @@ EOF
EOF
;;
+ dragonfly*)
+ os_type=DRAGONFLY
+ cat >> confdefs.h <<\EOF
+#define DRAGONFLY 1
+EOF
+
+ ;;
hp*)
os_type=HPUX
cat >> confdefs.h <<\EOF
@@ -7666,7 +7673,7 @@ found=n
fi
done
- if test $found = n; then
+ if test $found = y; then
echo $ac_n "checking for gettext in -lintl""... $ac_c" 1>&6
echo "configure:7672: checking for gettext in -lintl" >&5
ac_lib_var=`echo intl'_'gettext | sed 'y%./+-%__p_%'`
@@ -8619,7 +8628,7 @@ sed 's/%@/@@/; s/@%/@@/; s/%g\$/@g/; /@g
$ac_vpsub
$extrasub
s%@SHELL@%$SHELL%g
-s%@CFLAGS@%$CFLAGS%g
+s%@CFLAGS@%$CFLAGS $PTHREAD_CFLAGS%g
s%@CPPFLAGS@%$CPPFLAGS%g
s%@CXXFLAGS@%$CXXFLAGS%g
s%@FFLAGS@%$FFLAGS%g
@@ -8751,6 +8760,7 @@ CONFIG_FILES=\${CONFIG_FILES-"Makefile:s
src/Cinput/zh_hex/Makefile \
src/Cinput/gen_inp/Makefile \
src/Cinput/bimsphone/Makefile \
+ src/Cinput/chewing/Makefile \
src/util/Makefile \
src/util/cin2tab/Makefile \
src/util/testprog/Makefile \