pkgsrc/mail/etpan/patches/patch-aa
xtraeme d8c9115abe Initial import of etpan-0.6.1 from pkgsrc-wip.
etPan is a mail client that is based on libEtPan!

Features:

* IMAP4rev1 / POP3 / NNTP / mbox / mh / maildir
* virtual folder tree
* multiple folder views and message views
* smart multi-threading
* PGP signing and encryption (using GnuPG as external command)
* S/MIME signing and encryption (using OpenSSL as external command)
* SPAM process (using bogofilter as external command)
* user interface for configuration edition
2005-08-06 05:32:19 +00:00

43 lines
1.2 KiB
Text

$NetBSD: patch-aa,v 1.1.1.1 2005/08/06 05:32:19 xtraeme Exp $
--- src/Makefile.in.orig 2005-08-05 21:37:44.000000000 +0200
+++ src/Makefile.in 2005-08-05 21:38:46.000000000 +0200
@@ -7,14 +7,14 @@
bindir = @bindir@
INSTALL = @INSTALL@
-SHELL = /bin/sh
-RM = rm -fr
+#SHELL = /bin/sh
+#RM = rm -fr
# CPPFLAGS is duplicated for FreeBSD compatibility
-CFLAGS = @DEFS@ @CFLAGS@ @CPPFLAGS@
-CPPFLAGS = -I.. -Ilibversit @CPPFLAGS@
-CC = @CC@
+CFLAGS += @DEFS@
+CPPFLAGS += -I.. -Ilibversit
+#CC = @CC@
PROGS = etpan
-LDFLAGS = @LDFLAGS@ @LIBS@
+LINKERFLAGS = @LDFLAGS@ @LIBS@
OBJ = \
etpan-config.o \
@@ -104,7 +104,7 @@
all: all-recursive $(PROGS)
etpan: $(OBJ)
- $(CC) -o $@ $(OBJ) $(VERSIT_OBJ) $(LDFLAGS)
+ $(CC) -o $@ $(OBJ) $(VERSIT_OBJ) $(LINKERFLAGS)
install: etpan
$(INSTALL) -m 755 -d $(bindir)
@@ -123,7 +123,7 @@
$(CC) $(CPPFLAGS) $(CFLAGS) -c -o $@ $<
etpan-ldap-test: etpan-ldap-test.o etpan-ldap.o
- $(CC) -o $@ etpan-ldap-test.o etpan-ldap.o $(LDFLAGS)
+ $(CC) -o $@ etpan-ldap-test.o etpan-ldap.o $(LINKERFLAGS)
dep:
$(CC) -M $(CFLAGS) $(OBJ:.o=.c) etpan-ldap-test.c | sed 's,\( /[^ ]*\),,g;/^ *\\$$/d' > .deps