pkgsrc/security/nessus-libraries/patches/patch-ab
jmc 1320d94a07 Any version of m4 before 1.5.3 has a bug where in certain conditions it'll add
0xff as the last byte of output. Pass the m4 output through tr to strip it.
2002-03-12 20:58:42 +00:00

34 lines
1 KiB
Text

$NetBSD: patch-ab,v 1.2 2002/03/12 20:58:42 jmc Exp $
--- libpeks/gmp3/mpn/Makefile.in.orig Sun Aug 6 19:46:54 2000
+++ libpeks/gmp3/mpn/Makefile.in Tue Mar 12 20:46:49 2002
@@ -142,7 +142,7 @@
# COMPILE minus CC. FIXME: Really pass *_CFLAGS to CPP?
COMPILE_FLAGS = \
- $(DEFS) $(INCLUDES) $(AM_CPPFLAGS) $(CPPFLAGS) $(AM_CFLAGS) $(CFLAGS)
+ $(DEFS) $(INCLUDES) $(AM_CPPFLAGS) $(CPPFLAGS)
SUFFIXES = .s .S .asm
@@ -453,7 +453,7 @@
# *.m4 are preprocessed with m4.
.asm.o:
- $(M4) -DOPERATION_$* $< >tmp-$*.s
+ $(M4) -DOPERATION_$* $< | tr -d '\377' >tmp-$*.s
$(CCAS) $(COMPILE_FLAGS) tmp-$*.s -o $@
rm -f tmp-$*.s
.asm.obj:
@@ -461,9 +461,9 @@
$(CCAS) $(COMPILE_FLAGS) tmp-$*.s -o $@
rm -f tmp-$*.s
.asm.lo:
- $(M4) -DPIC -DOPERATION_$* $< >tmp-$*.s
+ $(M4) -DPIC -DOPERATION_$* $< | tr -d '\377' >tmp-$*.s
$(LIBTOOL) --mode=compile $(CCAS) $(COMPILE_FLAGS) tmp-$*.s -o $@
- $(M4) -DOPERATION_$* $< >tmp-$*.s
+ $(M4) -DOPERATION_$* $< | tr -d '\377' >tmp-$*.s
$(CCAS) $(COMPILE_FLAGS) tmp-$*.s -o $*.o
rm -f tmp-$*.s