editors/xemacs-current editors/xemacs-current-nox11 The latter is now just editors/xemacs-current built with a specific set of options. Changes include: + Rename the "xaw" option to "lucid" to match the option name used in xemacs/options.mk. Also comment out the "esound" option which isn't fully supported yet. Add some comments to the options.mk file to make it a little easier to understand. XXX Should probably add a pgsql option as this version of XEmacs has XXX some sort of PostgreSQL support. Also need to sort out native XXX sound support. + Remove Makefile.common and move all logic into xemacs-current/Makefile and xemacs-current/options.mk. + As of version 21.5, xemacs switched to using GNU autoconf, so set GNU_CONFIGURE=yes. + Include termcap.buildlink3.mk to properly deal with termcap/curses issues (xemacs needs termcap). Drop the --without-ncurses setting as the issue is handled by termcap.buildlink3.mk. + Be slightly more aware of ${X11_TYPE} == "modular" by not referring to ${X11BASE} in that case. + Include buildlink3.mk files for zlib and gettext, which are detected automatically if they're in the base system. Gettext is needed for MULE support. + In the Makefile and the PLIST, don't substitute for ${EMACSVER}. Instead substitute for ${DISTNAME} so the PLIST looks closer to xemacs/PLIST. + Add patch-al which handles a difference between bmake and gmake in using $< in a makefile target. + Support DESTDIR installation by adding INSTALL_MAKE_FLAGS to override where files are installed during the install phase. + Honor PKGMANDIR. + Bump the PKGREVISION for xemacs-current and xemacs-current-nox11 to 1. Both packages now track and use the same PKGREVISION number.
13 lines
375 B
Text
13 lines
375 B
Text
$NetBSD: patch-al,v 1.1 2008/04/24 21:32:47 jlam Exp $
|
|
|
|
--- modules/common/Makefile.common.orig 2005-11-22 02:14:54.000000000 -0500
|
|
+++ modules/common/Makefile.common
|
|
@@ -98,7 +98,7 @@ extraclean: realclean
|
|
-$(RM) *~ \#*
|
|
|
|
install: $(OBJECT_TO_BUILD)
|
|
- $(INSTALL_PROGRAM) $< $(INSTALLPATH)
|
|
+ $(INSTALL_PROGRAM) $(OBJECT_TO_BUILD) $(INSTALLPATH)
|
|
|
|
##
|
|
## Local Variables:
|