b492e9d535
patch-commoncpp_address.cpp breaks the build. I'm not seeing how bitset would use the C++ stdlib version, since <bitset> isn't included. OpenSSL and GNUTLS are package options, defaulting to openssl. Set PKG_BUILD_OPTIONS.ucommon accordingly. Major shared library change, so update buildlink3.mk accordinly. Updates to dependant packages coming shortly. From ChangeLog: Changes from 6.3.0 to 6.3.1 - copyright assignment to Cherokees of Idaho - introduction of ucommon cmake hosted macros - simplified doxygen doc support - convergence of automake and cmake builds - make utils easier for source introspection - converted for cmake builds on debian - count for String::check should be size_t - string bounds checking Changes from 6.2.3 to 6.3.0 - remove legacy cmodel support - modernize library usage - simplify autoconf and cmake - introduce sysruntime... - cleanup memory operators.... Changes from 6.2.2 to 6.2.3 - a few socket fixes, mostly windows related... Changes from 6.2.1 to 6.2.2 - bumped gnutls to 3.0.0 or later... - lots of bug fixes and general cleanup - socket endian issues and other things for ccrtp - templated newp and freep handle management Changes from 6.2.0 to 6.2.1 - datetime: fix const inconsistency - fsys: cached error variable must be mutable - replacment new/delete cannot be declared inline - fix exception specifier clash for c++11 Changes from 6.1.11 to 6.2.0 - standardized cmake paths and stand-alone usages - gnutls support in cmake - unified openssl checks, even works for windows - improved openssl support, new static crypto option - pkgconfig usable in win32, other win32 fixes - fixes for mac build & optional disable of utils - upticked abi version to 7, should have happened with 10/11? Changes from 6.1.10 to 6.1.11 - any addr and overloads in commoncpp - cmake abi fix and other apple specific issues - stream fixes, sflphone recommended changes, and other updates - key protocol added - cleaner build for binding without resolver - cleanup and fixes for commoncpp peering... - UDPSocket: use ucommon::Socket::address - Socket::address: add setAny(sockaddr*), setLoopback(sockaddr*) Changes from 6.1.9 to 6.1.10 - for next release - iso cleaness - Fix memory leak in DateTime ctor - Fix utf8::count() - secure::erase() should be more secure Changes from 6.1.8 to 6.1.9 - ost::Socket: use ucommon::Socket for join(), drop() implementations - back to native threading model for mingw - Socket::store: use existing len method - Socket::address: allow printing to std::ostream - Socket::address: use in_port_t for port numbers - Socket::join, ::drop: allow to set interface index for IPv6 Changes from 6.1.7 to 6.1.8 - mingw libstdc++ c++11 support now requires winpthread - more android related updates Changes from 6.1.6 to 6.1.7 - lots of android related updates Changes from 6.1.5 to 6.1.6 - some windows and mingw fixes - Socket::address::print(): minor fixes - Socket::address: fix constructor documentation - Socket::address: add unit tests for print() - Socket::address: add print() method - Socket::address: add withPort() - Socket::address: add constructors from standard addr types - Socket::address: use existing len() method. Changes from 6.1.4 to 6.1.5 - key merge on load for 6.1.5 Changes from 6.1.3 to 6.1.4 - lots of namespace usage cleanup - Socket::address: add unit tests for new features - Socket::address: add isAny, setAny, isLoopback, setLoopback, any, loopback - Socket::address: convert port to network byte order - ost::Socket: add compatibility with ucommon::Socket::address - we don't want commoncpp configs if no lib made - Socket::address: add equality operator, getPort, setPort, getSize - improved cmake and added srpm, todo make targets Changes from 6.1.2 to 6.1.3 - revised unixaddr buffer overflow issue Changes from 6.1.1 to 6.1.2 - updated contacts, fsf address, and copyright - revised cmake build - added setgroups from ucommon 6.1.0 to 6.1.1 - module flag support for older commoncpp packages - fix for commoncpp pc file - some additional original classes mapped to commoncpp - default Semaphore constructor now valid special case
15 lines
407 B
Text
15 lines
407 B
Text
$NetBSD: patch-configure,v 1.1 2015/04/18 02:43:24 rodent Exp $
|
|
|
|
Fix portability failure.
|
|
|
|
--- configure.orig 2015-03-24 23:44:16.000000000 +0000
|
|
+++ configure
|
|
@@ -16782,7 +16782,7 @@ if test "${enable_utils+set}" = set; the
|
|
enableval=$enable_utils;
|
|
fi
|
|
|
|
-if test x"$enable_utils" == "xno"; then
|
|
+if test x"$enable_utils" = "xno"; then
|
|
if false; then
|
|
BUILD_UTILS_TRUE=
|
|
BUILD_UTILS_FALSE='#'
|