5d8b26d21e
Changes: 2006-11-10 Mikio Hirabayashi - The utility API was enhanced. - A bug related to B+ tree API for Ruby was fixed. - Release: 1.8.75
44 lines
1.6 KiB
Text
44 lines
1.6 KiB
Text
$NetBSD: patch-ab,v 1.3 2007/03/05 15:56:27 obache Exp $
|
|
|
|
--- perl/Makefile.in.orig 2006-11-12 21:18:12.000000000 +0900
|
|
+++ perl/Makefile.in
|
|
@@ -21,16 +21,16 @@ MYDOCS = plspex.html plspex-ja.html plap
|
|
prefix = @prefix@
|
|
exec_prefix = @exec_prefix@
|
|
MYBINDIR = @bindir@
|
|
-MYDATADIR = @datadir@/$(PACKAGE)/perl
|
|
+MYDATADIR = @datadir@/doc/$(PACKAGE)/perl
|
|
DESTDIR =
|
|
|
|
# Building binaries
|
|
CC = gcc
|
|
-INC = -I. -I../.. -I$(HOME)/include -I/usr/local/include
|
|
+INC = -I. -I../..
|
|
OPTIMIZE = -O2
|
|
LD = gcc
|
|
-LIBS = -L../.. -I$(HOME)/lib -L/usr/local/lib -lqdbm @LIBS@
|
|
-RUNENV = LD_LIBRARY_PATH=.:..:../..:/usr/local/lib:$(HOME)/lib
|
|
+LIBS = -L../.. -lqdbm @LIBS@
|
|
+RUNENV = LD_LIBRARY_PATH=.:..:../..
|
|
|
|
|
|
|
|
@@ -42,15 +42,15 @@ RUNENV = LD_LIBRARY_PATH=.:..:../..:/usr
|
|
all :
|
|
cd depot && [ -f Makefile ] || \
|
|
$(RUNENV) perl Makefile.PL CC="$(CC)" INC="$(INC)" OPTIMIZE="$(OPTIMIZE)" \
|
|
- LD="$(LD)" LIBS="$(LIBS)" PREFIX="$(prefix)" ; \
|
|
+ LD="$(LD)" LIBS="$(LIBS)" PREFIX="$(prefix)" INSTALLDIRS=vendor ; \
|
|
$(RUNENV) make
|
|
cd curia && [ -f Makefile ] || \
|
|
$(RUNENV) perl Makefile.PL CC="$(CC)" INC="$(INC)" OPTIMIZE="$(OPTIMIZE)" \
|
|
- LD="$(LD)" LIBS="$(LIBS)" PREFIX="$(prefix)" ; \
|
|
+ LD="$(LD)" LIBS="$(LIBS)" PREFIX="$(prefix)" INSTALLDIRS=vendor ; \
|
|
$(RUNENV) make
|
|
cd villa && [ -f Makefile ] || \
|
|
$(RUNENV) perl Makefile.PL CC="$(CC)" INC="$(INC)" OPTIMIZE="$(OPTIMIZE)" \
|
|
- LD="$(LD)" LIBS="$(LIBS)" PREFIX="$(prefix)" ; \
|
|
+ LD="$(LD)" LIBS="$(LIBS)" PREFIX="$(prefix)" INSTALLDIRS=vendor ; \
|
|
$(RUNENV) make
|
|
@printf '\n'
|
|
@printf '#================================================================\n'
|