pkgsrc/lang/openjdk7/patches/patch-jdk_make_com_sun_nio_Makefile
ryoon c046b2c61b Update to 1.7.76
* Disable SCTP support under NetBSD.

Changelog:
From: http://www.oracle.com/technetwork/java/javase/7u76-relnotes-2389087.html

IANA Data 2014j

JDK 7u76 contains IANA time zone data version 2014j. For more information, refer to Timezone Data Versions in the JRE Software.

New Features and Changes

SSLv3 is disabled by default

Starting with JDK 7u75 release, the SSLv3 protocol (Secure Socket Layer) has been deactivated and is not available by default. See the java.security.Security property jdk.tls.disabledAlgorithms in <JRE_HOME>/lib/security/java.security file.

If SSLv3 is absolutely required, the protocol can be reactivated by removing "SSLv3" from the jdk.tls.disabledAlgorithms property in the java.security file or by dynamically setting this Security property to "true" before JSSE is initialized.

It should be noted that SSLv3 is obsolete and should no longer be used.
Changes to Java Control Panel

Starting with 7u75 release, SSLv3 protocol is removed from Java Control Panel Advanced options.

If the user needs to use SSLv3 for applications, re-enable it manually as follows:

    Enable SSLv3 protocol on JRE level: as described in the previous section.
    Enable SSLv3 protocol on deploy level: edit the deployment.properties file and add the following:

    deployment.security.SSLv3=true
2015-01-27 12:31:06 +00:00

19 lines
467 B
Text

$NetBSD: patch-jdk_make_com_sun_nio_Makefile,v 1.1 2015/01/27 12:31:06 ryoon Exp $
* NetBSD has no SCTP support.
--- jdk/make/com/sun/nio/Makefile.orig 2015-01-26 15:20:56.000000000 +0000
+++ jdk/make/com/sun/nio/Makefile
@@ -29,8 +29,12 @@
BUILDDIR = ../../..
include $(BUILDDIR)/common/Defs.gmk
+
+# disable for NetBSD
+ifneq ($(OS_VENDOR), NetBSD)
include $(BUILDDIR)/common/Subdirs.gmk
SUBDIRS = sctp
+endif
all build clean clobber::
$(SUBDIRS-loop)