pkgsrc/devel/sdcc3/patches/patch-support_sdbinutils_libiberty_Makefile.in
bouyer db0d0a94f3 Update to 3.6.0, fixing boost-related build issue.
Changes since 3.5.0:
- Merged upstream binutils 2.25
- New memory management with lower overhead
- Changed default language dialect to --std-sdcc11
- Diagnostic for missing type specifier: No implicit int outside of C90 mode
  anymore
- C11 generic selections
- char type is now unsigned by default (old behaviour can be restored
  using --fsigned-char)
- Character constants are now of type int instead of char.
- ISO C95 and ISO C11 wide character constants
- ISO C95 and ISO C11 wide string literals
- Basic standard library support for wide characters: c16rtomb(), mbrtoc16(),
  mbsinit(), mbtowc(), mbrlen(), mbrtoc32, c32rtomb(), mbrtowc(), wcrtomb(),
  mblen(), wctomb()
- Treat all ports the same in the manual (i.e. mcs51-specific stuff is now
  clearly described as such)
- Reorganized interrupt handling for z80, z180, r2k, r3ka, tlcs90, gbz80
  backends
- Workaround for stm8 division hardware bug
- ELF/DWARF support for stm8
- Output symbol table for ELF
- pic16 port now uses standard-compliant crt0iz that initializes static and
  globals to 0 by default

Numerous feature requests and bug fixes are included as well.
2016-06-25 17:48:15 +00:00

13 lines
670 B
Text

$NetBSD: patch-support_sdbinutils_libiberty_Makefile.in,v 1.3 2016/06/25 17:48:15 bouyer Exp $
--- support/sdbinutils/libiberty/Makefile.in.orig 2015-07-01 10:37:09.000000000 +0200
+++ support/sdbinutils/libiberty/Makefile.in 2016-06-25 13:17:19.000000000 +0200
@@ -361,7 +361,7 @@
# multilib-specific flags, it's overridden by FLAGS_TO_PASS from the
# default multilib, so we have to take CFLAGS into account as well,
# since it will be passed the multilib flags.
-MULTIOSDIR = `$(CC) $(CFLAGS) -print-multi-os-directory`
+MULTIOSDIR = "."
install_to_libdir: all
if test -n "${target_header_dir}"; then \
${mkinstalldirs} $(DESTDIR)$(libdir)/$(MULTIOSDIR); \