6d8afaf59c
This release fixes zillions of bugs (most notably, game saving/loading now works). Also included is PNG support. There are too many little changes to note, so see the ChangeLog for details.
22 lines
1.1 KiB
Text
22 lines
1.1 KiB
Text
$NetBSD: patch-ac,v 1.2 2004/08/25 20:26:18 snj Exp $
|
|
|
|
--- ruamoko/cl_menu/Makefile.am.orig 2004-02-13 21:02:25.000000000 -0800
|
|
+++ ruamoko/cl_menu/Makefile.am 2004-08-24 15:21:15.000000000 -0700
|
|
@@ -7,7 +7,7 @@ QFCC_DEP=$(top_builddir)/tools/qfcc/sour
|
|
QFCC=$(QFCC_DEP)
|
|
QCFLAGS=-qq -g -Werror
|
|
QCPPFLAGS=-I. -I$(srcdir) -I$(top_builddir)/ruamoko/include -I$(top_srcdir)/ruamoko/include -I$(top_builddir)/include -I$(top_srcdir)/include
|
|
-GZIP=if echo $@ | grep -q .gz; then gzip -f `basename $@ .gz`; if test -f `basename $@ .dat.gz`.sym; then gzip -f `basename $@ .dat.gz`.sym; fi; fi
|
|
+XGZIP=if echo $@ | grep -q .gz; then gzip -f `basename $@ .gz`; if test -f `basename $@ .dat.gz`.sym; then gzip -f `basename $@ .dat.gz`.sym; fi; fi
|
|
if HAVE_ZLIB
|
|
GZ=.gz
|
|
else
|
|
@@ -40,7 +40,7 @@ menu_obj=$(addsuffix .qfo,$(basename $(m
|
|
|
|
menu.dat$(GZ): $(menu_obj) $(QFCC_DEP) ../lib/libcsqc.a ../lib/libr.a ../gui/libgui.a
|
|
$(QFCC) $(QCFLAGS) -p $(STRIP) -o menu.dat $(menu_obj) ../gui/libgui.a ../lib/libcsqc.a ../lib/libr.a
|
|
- $(GZIP)
|
|
+ $(XGZIP)
|
|
|
|
EXTRA_DIST= $(menu_src) \
|
|
Frame.h HUD.h \
|