pkgsrc/mail/getmail/patches/patch-setup.py
schmonz 50286d0a91 Update to 5.0. From the changelog:
- new release numbering scheme; previous version numbers were just getting
  too high.
- catch and ignore/exit cleanly after reset connection in IMAP IDLE mode.
  Thanks:  Stephan Schulz.
- allow specifying an expected SSL certificate hostname, for when the
  server's certificate does not match the domain name used to connect to
  it.  Thanks:  "Andre".
- fix error message not actually giving the header field name incorrectly
  specified as containing the envelope recipient address.  Thanks:  Hardy
  Braunsdorf.
- add new password_command configuration parameter for retrievers, allowing
  getmail to retrieve the account password from any arbitrary external
  command.  Suggestion:  "ng0".
2017-07-16 00:16:43 +00:00

30 lines
686 B
Python

$NetBSD: patch-setup.py,v 1.1 2017/07/16 00:16:43 schmonz Exp $
Use standard pkgsrc paths, and don't install RPM spec file.
--- setup.py.orig 2007-11-23 16:26:55.000000000 +0000
+++ setup.py
@@ -39,13 +39,12 @@ GETMAILDOCDIR = os.path.join(
datadir or prefix,
'share',
'doc',
- 'getmail-%s' % __version__
+ 'getmail'
)
GETMAILMANDIR = os.path.join(
datadir or prefix,
- 'share',
- 'man',
+ os.environ["PKGMANDIR"],
'man1'
)
@@ -100,7 +99,6 @@ setup(
data_files=[
(GETMAILDOCDIR, [
'./README',
- './getmail.spec',
'docs/BUGS',
'docs/COPYING',
'docs/CHANGELOG',