some 64 bit related compiler warnings to fix. - while here, use libffm if on an alpha for faster math. In this case 20-30% faster.
19 lines
555 B
Text
19 lines
555 B
Text
$NetBSD: patch-aa,v 1.3 2001/02/09 11:29:37 dmcmahill Exp $
|
|
|
|
--- src/fasthenry/Makefile.default.orig Tue Nov 12 14:18:58 1996
|
|
+++ src/fasthenry/Makefile.default Thu Feb 8 20:08:41 2001
|
|
@@ -1,3 +1,3 @@
|
|
-CFLAGS = -O -DFOUR
|
|
+CFLAGS = -O2 -DFOUR
|
|
|
|
SHELL = /bin/sh
|
|
@@ -23,6 +23,8 @@
|
|
NONUNIHEAD = gp.h
|
|
|
|
+LIBS?= -lm
|
|
+
|
|
fasthenry: $(OBJS) $(MOBJS) $(NONUNIOBJS) $(SPLIB)
|
|
- $(CC) -o fasthenry $(CFLAGS) $(OBJS) $(MOBJS) $(NONUNIOBJS) $(SPLIB) -lm
|
|
+ $(CC) -o fasthenry $(CFLAGS) $(OBJS) $(MOBJS) $(NONUNIOBJS) $(SPLIB) $(LIBS)
|
|
mv fasthenry $(BIN)/fasthenry
|
|
|