c53741bc22
including support for relocable programs, Qt support, separation of the PO processing functions into a separate library and more. Reorganise the gettext infrastructure by splitting of the tools into devel/gettext-tools, which will be used by the tools framework. The remaining devel/gettext package contains gettextize and autopoint aka the infrastructure to embbed gettext into a package. Due to the ABI and API changes, a recursive revision bump will follow. Take blaim by receiving the maintainer hat. With input from jlam@, reed@ and wiz@.
23 lines
1.1 KiB
Text
23 lines
1.1 KiB
Text
$NetBSD: patch-ab,v 1.3 2006/02/05 22:45:54 joerg Exp $
|
|
|
|
--- intl/Makefile.in.orig Thu Jul 25 08:49:57 2002
|
|
+++ intl/Makefile.in Mon Mar 15 14:39:58 2004
|
|
@@ -156,8 +156,7 @@ libintl.la libgnuintl.la: $(OBJECTS)
|
|
$(CC) $(CPPFLAGS) $(CFLAGS) $(XCFLAGS) $(LDFLAGS) -o $@ \
|
|
$(OBJECTS) @LTLIBICONV@ @INTL_MACOSX_LIBS@ $(LIBS) -lc \
|
|
-version-info $(LTV_CURRENT):$(LTV_REVISION):$(LTV_AGE) \
|
|
- -rpath $(libdir) \
|
|
- -no-undefined
|
|
+ -rpath $(libdir)
|
|
|
|
# Libtool's library version information for libintl.
|
|
# Before making a gettext release, the gettext maintainer must change this
|
|
@@ -264,7 +263,7 @@ install-exec: all
|
|
$(mkinstalldirs) $(DESTDIR)$(libdir) $(DESTDIR)$(includedir); \
|
|
$(INSTALL_DATA) libintl.h $(DESTDIR)$(includedir)/libintl.h; \
|
|
$(LIBTOOL) --mode=install \
|
|
- $(INSTALL_DATA) libintl.$la $(DESTDIR)$(libdir)/libintl.$la; \
|
|
+ $(BSD_INSTALL_LIB) libintl.$la $(DESTDIR)$(libdir)/libintl.$la; \
|
|
if test "@RELOCATABLE@" = yes; then \
|
|
dependencies=`sed -n -e 's,^dependency_libs=\(.*\),\1,p' < $(DESTDIR)$(libdir)/libintl.la | sed -e "s,^',," -e "s,'\$$,,"`; \
|
|
if test -n "$$dependencies"; then \
|