pkgsrc/audio/picard/patches/patch-aa

15 lines
867 B
Text

$NetBSD: patch-aa,v 1.1.1.1 2009/07/07 09:39:22 drochner Exp $
--- setup.py.orig 2009-06-16 17:57:10.000000000 +0200
+++ setup.py
@@ -370,8 +370,8 @@ class picard_config(config):
if have_pkgconfig:
if self.pkgconfig_check_module('avcodec', 'libavcodec libavformat'):
include_dirs = cflags_to_include_dirs(cfg.get('avcodec', 'cflags'))
- if self.try_compile('#include <avcodec.h>', include_dirs=include_dirs):
- cfg.set('avcodec', 'cflags', cfg.get('avcodec', 'cflags') + ' -DUSE_OLD_FFMPEG_LOCATIONS')
+ if self.try_compile('#include <libavcodec/avcodec.h>', include_dirs=include_dirs):
+ pass
else:
self.check_lib('avcodec', 'av_open_input_file', ['avcodec.h', 'avformat.h'], [['avcodec', 'avformat'], ['avcodec-51', 'avformat-51']])