pkgsrc/net/vncviewer/patches/patch-ac
joerg d26cf36e57 - fine grained X11 dependencies for packages which have either USE_IMAKE
or USE_X11BASE set, but don't include mk/x11.buildlink3.mk directly or
  via buildlink3.mks
- introduce BUILDLINK_PREFIX.libXpm as alias for BUILDLINK_PREFIX.xpm
  in the !modular case
- fix some cases where the check for libX11 couldn't work at all by using
  C++ for compilation without including the proper headers

Verified using a full X11_TYPE=xorg bulk build without additional
breakage. Discussed with salo@, wiz@ and send to packages@ for feedback.
2006-12-27 13:37:35 +00:00

16 lines
501 B
Text

$NetBSD: patch-ac,v 1.1 2006/12/27 13:37:39 joerg Exp $
--- configure.orig 2006-12-17 20:33:25.000000000 +0000
+++ configure
@@ -1230,9 +1230,10 @@ if test "$ac_x_libraries" = NO; then
cat > conftest.$ac_ext <<EOF
#line 1232 "configure"
#include "confdefs.h"
+#include <X11/Intrinsic.h>
int main() {
-${x_direct_test_function}()
+${x_direct_test_function}(0)
; return 0; }
EOF
if { (eval echo configure:1239: \"$ac_link\") 1>&5; (eval $ac_link) 2>&5; } && test -s conftest${ac_exeext}; then