799e93181f
pkgsrc change - Take matainer ship by me. - Introduce options.mk for PAM configure option. - Minor clean up of Makefile. - Added quick changes to avoid using <openssl/des.h>. netatalk changes Changes in 1.6.4a ================= * FIX: insecure tempfile handling bug in etc2ps.sh, found by Trustix, CAN-2004-0974. Changes in 1.6.4 ================ * NEW: afpd: Using the mswindows option now implicitly specifies usedots. [Sam Noble] * UPD: afpd.8: Updated the option documentation. [Thomas Kaiser, Sebastian Rittau] * FIX: configure: Removed broken --with-flock-locks option. [Bj\M-C\M-6rn Fernhomberg] * FIX: libatalk: Do not log network probe (OSX 10.3). [Didier Gautheron] * FIX: libatalk: Deadlock in signal handlers. [Didier] * FIX: libatalk: Compilation with Linux kernel 2.6 fixed. [Sebastian, Bj\M-C\M-6rn] * FIX: afpd: Solaris compile issues. [Bj\M-C\M-6rn] * FIX: afpd: If connection broke in dsi_tickle the child did never die. [Bj\M-C\M-6rn] * FIX: afpd: Catsearch, fixes a possible segmentation fault. [Bj\M-C\M-6rn] * FIX: afpd: Compilation issues. [Olaf Hering, Sebastian] * FIX: cnid: Fix compile problems on Tru64. [Burkhard Schmidt] * FIX: megatron: Fixed an uninitialized variable. [Olaf] * FIX: installation: Don't overwrite PAM file if --enable-overwrite configure option is not set. [Sam, Ryan Cleary] * FIX: installation: Fixed BSD installation. [Toru TAKAMIZU] * FIX: docs: Removed ssl-dir/ssl-dirs confusion from doc/INSTALL. [Bj\M-C\M-6rn] Changes in 1.6.3 ================ * UPD: afpd: Infrastructural support for an upcoming Kerberos 5 UAM. [Sam Noble] * UPD: uams_dhx_passwd: Better random seed in Tru64. [Burkhard Schmidt] * FIX: afpd: Bug in AFP connection negotiation stage. [Sam] * FIX: afpd: Catsearch, when Mac and unix name differ, search on attributes. * FIX: afpd: Files could be opened for writing on read-only filesystems. * FIX: afpd: Debugging using SIGUSR1 was broken. [Stefan Muenkner] * FIX: afpd: Segfault after login. [Robby Griffin, Sean Bolton] * FIX: psf: Correct path to etc2ps.sh. * FIX: shell_utils: Don't distribute generated files. * FIX: aecho: -A option didn't work. [Chris Shiels] * FIX: configure: Berkeley DB path detection could be wrong. [Stefan] * FIX: Automake build fixes.
48 lines
1.8 KiB
Text
48 lines
1.8 KiB
Text
$NetBSD: patch-ac,v 1.2 2005/06/05 23:40:56 taca Exp $
|
|
|
|
The original commit message for this patch:
|
|
|
|
http://mail-index.netbsd.org/source-changes/1999/09/17/0023.html
|
|
|
|
Patch from Juergen Hannken-Illjes, which should solve PR#8308 (net 0 is
|
|
reserved for lo0, it can't be used on other interfaces).
|
|
|
|
Here is PR #8308:
|
|
|
|
http://www.NetBSD.org/cgi-bin/query-pr-single.pl?number=8308
|
|
|
|
and also the change that exposed the bug:
|
|
|
|
http://mail-index.netbsd.org/source-changes/1999/08/24/0035.html
|
|
|
|
and finally, the discussion referred to in the above change:
|
|
|
|
http://mail-index.netbsd.org/tech-net/1999/06/30/0002.html
|
|
http://mail-index.netbsd.org/tech-net/1999/07/01/0005.html
|
|
http://mail-index.netbsd.org/tech-net/1999/07/01/0007.html
|
|
http://mail-index.netbsd.org/tech-net/1999/07/02/0003.html
|
|
http://mail-index.netbsd.org/tech-net/1999/07/02/0016.html
|
|
http://mail-index.netbsd.org/tech-net/1999/07/02/0017.html
|
|
http://mail-index.netbsd.org/tech-net/1999/07/02/0018.html
|
|
http://mail-index.netbsd.org/tech-net/1999/07/02/0020.html
|
|
http://mail-index.netbsd.org/tech-net/1999/07/02/0022.html
|
|
http://mail-index.netbsd.org/tech-net/1999/07/03/0004.html
|
|
|
|
|
|
--- etc/atalkd/main.c.orig Sat Oct 5 08:20:13 2002
|
|
+++ etc/atalkd/main.c
|
|
@@ -278,12 +278,12 @@ static void as_timer(int sig)
|
|
LOG(log_info, logtype_atalkd, "config for no router" );
|
|
|
|
if ( iface->i_flags & IFACE_PHASE2 ) {
|
|
- iface->i_rt->rt_firstnet = 0;
|
|
+ iface->i_rt->rt_firstnet = htons(1);
|
|
iface->i_rt->rt_lastnet = htons( STARTUP_LASTNET );
|
|
setaddr( iface, IFACE_PHASE2,
|
|
iface->i_addr.sat_addr.s_net,
|
|
iface->i_addr.sat_addr.s_node,
|
|
- 0, htons( STARTUP_LASTNET ));
|
|
+ htons(1), htons( STARTUP_LASTNET ));
|
|
}
|
|
if ( looproute( iface, RTMP_ADD ) ) { /* -1 or 1 */
|
|
LOG(log_error, logtype_atalkd,
|