20 lines
555 B
Text
20 lines
555 B
Text
$NetBSD: patch-build_unix_Makefile,v 1.2 2013/10/28 23:47:56 joerg Exp $
|
|
|
|
GCC 4.7.2 breaks on the unrecognized -c89 switch. Use -std= instead.
|
|
|
|
--- build/unix/Makefile.orig 2010-08-27 17:50:07.000000000 +0000
|
|
+++ build/unix/Makefile
|
|
@@ -24,12 +24,10 @@ PFORTHAPP = pforth_standalone
|
|
WIDTHOPT=
|
|
|
|
FULL_WARNINGS = \
|
|
- -c89 \
|
|
+ -std=c89 \
|
|
-fsigned-char \
|
|
-fno-builtin \
|
|
-fno-unroll-loops \
|
|
- -fpeephole \
|
|
- -fno-keep-inline-functions \
|
|
-pedantic \
|
|
-Wcast-qual \
|
|
-Wall \
|