* lib/dlopen.c: log the reason for opendir() failure when loading plugin. * lib/common.c: honor log level setting * sample/sample-client.c, sample/sample-server.c: Fixed several 64 bit portability warnings. * utils/testsuite.c: Fixed several 64 bit portability warnings. * utils/saslpasswd.c: Fixed typo in an auxprop name. * include/saslplug.h, lib/common.c, lib/saslint.h, lib/server.c: Added sasl_server_plugin_info(). * lib/common.c: initialize path in case caller didn't.
53 lines
1.9 KiB
Text
53 lines
1.9 KiB
Text
$NetBSD: patch-aq,v 1.4 2006/04/18 17:41:30 jlam Exp $
|
|
|
|
--- sasldb/Makefile.in.orig 2005-05-15 01:58:41.000000000 -0400
|
|
+++ sasldb/Makefile.in
|
|
@@ -239,26 +239,18 @@ extra_common_sources = db_none.c db_ndbm
|
|
EXTRA_DIST = NTMakefile
|
|
|
|
noinst_LTLIBRARIES = libsasldb.la
|
|
-noinst_LIBRARIES = libsasldb.a
|
|
|
|
libsasldb_la_SOURCES = allockey.c sasldb.h
|
|
EXTRA_libsasldb_la_SOURCES = $(extra_common_sources)
|
|
libsasldb_la_DEPENDENCIES = $(SASL_DB_BACKEND)
|
|
libsasldb_la_LIBADD = $(SASL_DB_BACKEND)
|
|
|
|
-# Prevent make dist stupidity
|
|
-libsasldb_a_SOURCES =
|
|
-EXTRA_libsasldb_a_SOURCES =
|
|
subdir = sasldb
|
|
mkinstalldirs = $(SHELL) $(top_srcdir)/config/mkinstalldirs
|
|
CONFIG_HEADER = $(top_builddir)/config.h
|
|
CONFIG_CLEAN_FILES =
|
|
LIBRARIES = $(noinst_LIBRARIES)
|
|
|
|
-libsasldb_a_AR = $(AR) cru
|
|
-libsasldb_a_LIBADD =
|
|
-am_libsasldb_a_OBJECTS =
|
|
-libsasldb_a_OBJECTS = $(am_libsasldb_a_OBJECTS)
|
|
LTLIBRARIES = $(noinst_LTLIBRARIES)
|
|
|
|
libsasldb_la_LDFLAGS =
|
|
@@ -278,10 +270,9 @@ LTCOMPILE = $(LIBTOOL) --mode=compile $(
|
|
CCLD = $(CC)
|
|
LINK = $(LIBTOOL) --mode=link $(CCLD) $(AM_CFLAGS) $(CFLAGS) \
|
|
$(AM_LDFLAGS) $(LDFLAGS) -o $@
|
|
-DIST_SOURCES = $(libsasldb_a_SOURCES) $(EXTRA_libsasldb_a_SOURCES) \
|
|
- $(libsasldb_la_SOURCES) $(EXTRA_libsasldb_la_SOURCES)
|
|
+DIST_SOURCES = $(libsasldb_la_SOURCES) $(EXTRA_libsasldb_la_SOURCES)
|
|
DIST_COMMON = Makefile.am Makefile.in
|
|
-SOURCES = $(libsasldb_a_SOURCES) $(EXTRA_libsasldb_a_SOURCES) $(libsasldb_la_SOURCES) $(EXTRA_libsasldb_la_SOURCES)
|
|
+SOURCES = $(libsasldb_la_SOURCES) $(EXTRA_libsasldb_la_SOURCES)
|
|
|
|
all: all-am
|
|
|
|
@@ -542,8 +533,6 @@ uninstall-am: uninstall-info-am
|
|
tags uninstall uninstall-am uninstall-info-am
|
|
|
|
|
|
-libsasldb.a: libsasldb.la $(SASL_DB_BACKEND_STATIC)
|
|
- $(AR) cru .libs/$@ $(SASL_DB_BACKEND_STATIC)
|
|
# Tell versions [3.59,3.63) of GNU make to not export all variables.
|
|
# Otherwise a system limit (for SysV at least) may be exceeded.
|
|
.NOEXPORT:
|