pkgsrc/devel/gdb/patches/patch-ad
seb ed7bae196b Update to gdb version 5.3.
Extract of changes below.

*** Changes in GDB 5.3:

* GNU/Linux shared library multi-threaded performance improved.

* ``gdbserver'' now supports multi-threaded applications on some targets

* GDB now supports C/C++ preprocessor macros.

* Multi-arched targets.
DEC Alpha (partial)                             alpha*-*-*
DEC VAX (partial)                               vax-*-*
NEC V850                                        v850-*-*
National Semiconductor NS32000 (partial)        ns32k-*-*
Motorola 68000 (partial)                        m68k-*-*
Motorola MCORE                                  mcore-*-*

* New targets.
Fujitsu FRV architecture added by Red Hat       frv*-*-*

* New native configurations
Alpha NetBSD                                    alpha*-*-netbsd*
SH NetBSD                                       sh*-*-netbsdelf*
MIPS NetBSD                                     mips*-*-netbsd*
UltraSPARC NetBSD                               sparc64-*-netbsd*

* OBSOLETE configurations and files
Mitsubishi D30V                                 d30v-*-*
OS/9000                                         i[34]86-*-os9k
IBM AIX PS/2                                    i[3456]86-*-aix
Fujitsu FR30                                    fr30-*-elf*
Motorola Delta 88000 running Sys V              m88k-motorola-sysv  or  delta88
Argonaut Risc Chip (ARC)                        arc-*-*
i386 running Mach 3.0                           i[3456]86-*-mach3*
i386 running Mach                               i[3456]86-*-mach*
i386 running OSF/1                              i[3456]86-*osf1mk*
HP/Apollo 68k Family                            m68*-apollo*-sysv*,
                                                m68*-apollo*-bsd*,
                                                m68*-hp-bsd*, m68*-hp-hpux*
I960 with MON960                                i960-*-coff

* OBSOLETE languages
CHILL, a Pascal like language used by telecommunications companies.

* REMOVED configurations and files

AMD 29k family via UDI                          a29k-amd-udi, udi29k
A29K VxWorks                                    a29k-*-vxworks
AMD 29000 embedded, using EBMON                 a29k-none-none
AMD 29000 embedded with COFF                    a29k-none-coff
AMD 29000 embedded with a.out                   a29k-none-aout

testsuite/gdb.hp/gdb.threads-hp/                directory

* New command "set max-user-call-depth <nnn>"

* Changes in FreeBSD/i386 native debugging.

Support for the "generate-core-file" has been added.

* New commands "dump", "append", and "restore".

* Improved "next/step" support on multi-processor Alpha Tru64.
2003-03-10 23:50:48 +00:00

27 lines
684 B
Text

$NetBSD: patch-ad,v 1.1 2003/03/10 23:50:49 seb Exp $
--- etc/Makefile.in.orig 2002-01-26 21:35:45.000000000 +0000
+++ etc/Makefile.in
@@ -67,20 +67,8 @@ info:
fi; \
done
-install-info: info
- $(SHELL) $(srcdir)/../mkinstalldirs $(infodir)
- if test ! -f standards.info; then cd $(srcdir); fi; \
- if test -f standards.info; then \
- for i in standards.info*; do \
- $(INSTALL_DATA) $$i $(infodir)/$$i; \
- done; \
- fi
- if test ! -f configure.info; then cd $(srcdir); fi; \
- if test -f configure.info; then \
- for i in configure.info*; do \
- $(INSTALL_DATA) $$i $(infodir)/$$i; \
- done; \
- fi
+install-info:
+ true
dvi:
for f in $(DVIFILES); do \