pkgsrc/geography/opencpn/patches/patch-plugins_grib_pi_CMakeLists.txt
bouyer 391da8f687 Update OpenCPN to 5.0.0. Changes since 4.8.8:
As a successor to OpenCPN Version 4.8, OpenCPN Version 5.0 contains many
new features and enhanced functions.
Among them are:

..Redesigned user interface, incorporating modern user interface elements and
  concepts.
..Support for multiple chart views simultaneously, using different charts
  display options if desired.
..User defined templates for easy recall of multiple configurations.
..Support for the widely available MBTiles chart format.
..Extended options for route and Waypoint creation.
..Expanded display of vector chart (ENC) information, including embedded
  images.
..Measurably improved performance and reliability over all supported platforms.
2019-03-25 11:34:05 +00:00

13 lines
495 B
Text

$NetBSD: patch-plugins_grib_pi_CMakeLists.txt,v 1.3 2019/03/25 11:34:05 bouyer Exp $
--- plugins/grib_pi/CMakeLists.txt.orig 2019-02-22 04:55:10.000000000 +0100
+++ plugins/grib_pi/CMakeLists.txt 2019-02-22 14:35:35.500028250 +0100
@@ -283,5 +285,8 @@
ENDIF(WIN32)
+IF(CMAKE_SYSTEM_NAME MATCHES ".*Linux")
+ SET_TARGET_PROPERTIES(${PROJECT_NAME} PROPERTIES COMPILE_FLAGS "-fPIC")
+ENDIF(CMAKE_SYSTEM_NAME MATCHES ".*Linux")
INCLUDE("../PluginLocalization.cmake")
PLUGIN_LOCALIZATION()