fcf436606c
do a patch refresh in xentools42 rather than split the patches for pass-through.c over 5 files, delete xentools42/patches/patch-CVE-2015-2756 and assemble all in xentools42/patches/patch-qemu-xen-traditional_hw_pass-through.c
26 lines
791 B
Text
26 lines
791 B
Text
$NetBSD: patch-firmware_etherboot_Makefile,v 1.2 2015/08/23 16:17:12 spz Exp $
|
|
|
|
--- firmware/etherboot/Makefile.orig 2014-09-02 06:22:57.000000000 +0000
|
|
+++ firmware/etherboot/Makefile
|
|
@@ -27,18 +27,10 @@ all: $(ROMS)
|
|
%.rom: $D/src/arch/i386/Makefile
|
|
$(MAKE) -C $D/src bin/$(*F).rom
|
|
|
|
-$T:
|
|
- if ! wget -O _$T $(IPXE_TARBALL_URL); then \
|
|
- $(GIT) clone $(IPXE_GIT_URL) $D.git; \
|
|
- (cd $D.git && $(GIT) archive --format=tar --prefix=$D/ \
|
|
- $(IPXE_GIT_TAG) | gzip >../_$T); \
|
|
- rm -rf $D.git; \
|
|
- fi
|
|
- mv _$T $T
|
|
+$D:
|
|
+ ln -sf $(WRKSRC)/../../ipxe $D
|
|
|
|
-$D/src/arch/i386/Makefile: $T Config
|
|
- rm -rf $D
|
|
- gzip -dc $T | tar xf -
|
|
+$D/src/arch/i386/Makefile: $D Config
|
|
for i in $$(cat patches/series) ; do \
|
|
patch -d $D -p1 --quiet <patches/$$i || exit 1 ; \
|
|
done
|